Error trying to load config from /etc/swift/proxy-server.conf: python-swiftclient

asked 2013-11-01 07:22:03 -0500

hettbox gravatar image

Hi, I upgrade swift to latest version from GitHub (84f494c0e74a1659d8ca2c1a4f83f23d18974450), but after try start proxy, i have error:

Starting proxy-server...(/etc/swift/proxy-server.conf) Error trying to load config from /etc/swift/proxy-server.conf: python-swiftclient

what could be wrong? thanks!

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2013-11-01 07:46:20 -0500

esedmehmet gravatar image

Can you share proxy.conf?

edit flag offensive delete link more
0

answered 2013-11-01 07:55:19 -0500

hettbox gravatar image

I did not change previous version config

[DEFAULT] #cert_file = /etc/swift/cert.crt #key_file = /etc/swift/cert.key bind_port = 8080 workers = 2 user = swift proxy_name = prx-01 client_timeout=10

log_name = swift log_facility = LOG_LOCAL0 log_level = DEBUG log_address = /dev/log log_headers = True

#object_chunk_size = 1048576 #client_chunk_size = 1048576

eventlet_debug = False

[pipeline:main] pipeline = healthcheck cache tempurl tempauth proxy-logging proxy-server

[filter:name_check] use = egg:swift#name_check forbidden_chars = '"`<> maximum_length = 255 forbidden_regexp = /./|/../|/.$|/..$

[app:proxy-server] use = egg:swift#proxy allow_account_management = true account_autocreate = true write_affinity = r1 write_affinity_node_count=1 read_affinity = r2=100, r1=100 sorting_method = affinity

[filter:tempurl] use = egg:swift#tempurl

[filter:formpost] use = egg:swift#formpost

[filter:tempauth] use = egg:swift#tempauth user_system_root = testpass .admin http://192.168.4.230:8080/v1/AUTH_system

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = 10.0.0.254:11211

[filter:proxy-logging] use = egg:swift#proxy_logging stomp_informing_interval = 10 stomp_host = 192.168.4.230

[filter:catch_errors] use = egg:swift#catch_errors

You can override the default log routing for this filter here:

set log_name = catch_errors

set log_facility = LOG_LOCAL0

set log_level = INFO

set log_headers = False

set log_address = /dev/log

[filter:slo] use = egg:swift#slo

max_manifest_segments = 1000

max_manifest_size = 2097152

min_segment_size = 1048576

edit flag offensive delete link more
0

answered 2013-11-01 07:57:51 -0500

hettbox gravatar image

With default config same error

edit flag offensive delete link more
0

answered 2013-11-01 08:05:51 -0500

hettbox gravatar image

Sorry, problem solved after reinstall all swift components.

edit flag offensive delete link more
0

answered 2013-11-01 18:42:47 -0500

clay-gerrard gravatar image

must have needed a python-swiftclient version bump

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-01 07:22:03 -0500

Seen: 294 times

Last updated: Nov 01 '13