Ask Your Question
0

Keystone won't ask me for an user/password to access all the machines

asked 2013-05-30 00:40:32 -0500

Trompetero gravatar image

updated 2013-06-08 22:26:08 -0500

fifieldt gravatar image

Hi, I Followed the guide described here:

https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/master/OpenStack_Grizzly_Install_Guide.rst (https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/master/OpenStackGrizzlyInstall_Guide.rst)

to build an allinone installation. It seems to work, but when I try to access from a remote computer via virt-manager, keystone lets me access every VM without authentication, it never asks me for an user or password. Did I misconfigured keystone? Thank you!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-05-30 04:54:02 -0500

fifieldt gravatar image

Hi,

If you can access VMs using virt-manager from a remote computer, and you don't have some other security mechanism setup to bypass the password (eg SSH keys setup for passwordless login), you should probably firewall that off quickly :)

Virt-manager is part of the hypervisor, rather than part of OpenStack. My recommendation is to read the "Overview of VNC Proxy" section of the official documentation: http://docs.openstack.org/trunk/openstack-compute/admin/content/getting-started-with-vnc-proxy.html

which explains how the VNC console is accessed via a secure mechanism using tokens.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-30 00:40:32 -0500

Seen: 85 times

Last updated: May 30 '13