error: swift cache could not be found in env!

asked 2013-12-29 11:45:21 -0500

fitros16 gravatar image

After installing everything under the instructions at openstack swift in my VM everything was going good until i typed the following 2 commands as the instructions said at http://docs.openstack.org/developer/swift/development_saio.html#partition-section (http://docs.openstack.org/developer/s...) The first was : curl -v -H 'X-Storage-User: test:tester' -H 'X-Storage-Pass: testing' http://127.0.0.1:8080/auth/v1.0 witch went good and the second: curl -v -H 'X-Auth-Token: ' and then i got 503 internal server error and at the syslog i got the error: proxyserver STDOUT: Error:root:Error: swift.cache could not be found in env! (txn: tx85b3cb5152984fa0b211e-0052c00503) (client_ip: 127.0.0.1) Any ideas why is this happening?

Thanks

edit retag flag offensive close merge delete

17 answers

Sort by » oldest newest most voted
0

answered 2014-01-03 09:37:49 -0500

fitros16 gravatar image

Thanks Mehmet Hacısalihoğlu, that solved my question.

edit flag offensive delete link more
0

answered 2014-01-02 11:47:02 -0500

fitros16 gravatar image

Hi, memcached.conf is https://drive.google.com/file/d/0B4uP_0R-AEKjT3lBdXZnVkFMOGs/edit?usp=sharing (https://drive.google.com/file/d/0B4uP...) and proxy-server.conf is https://drive.google.com/file/d/0B4uP_0R-AEKjVzEyUzh0LTNjbVk/edit?usp=sharing (https://drive.google.com/file/d/0B4uP...)

edit flag offensive delete link more
0

answered 2014-01-02 06:33:47 -0500

esedmehmet gravatar image

Hi,

Could you share proxy-server conf and memcached.conf?

edit flag offensive delete link more
0

answered 2014-01-02 12:46:11 -0500

esedmehmet gravatar image

Hi,

You can add "memcache_servers = 192.168.56130:11211" in [filter:cache] of your proxy-server.conf file.

proxy-server.conf [filter:cache] use = egg:swift#memcache memcache_servers = Proxy_server_ip:11211

#proxy_server_ip example 192.168.56.135

memcached.conf -l proxy_server_ip # -l 127.0.0.1 change proxy_server_ip

after you must restart to proxy and memcached service.

edit flag offensive delete link more
0

answered 2014-01-02 13:06:31 -0500

fitros16 gravatar image

where can i find my proxy server ip address? should i set it with bind_ip? Thanks

edit flag offensive delete link more
0

answered 2014-01-02 13:27:26 -0500

fitros16 gravatar image

After doing what you said and trying to start proxy server with the command: swift-proxy-server /etc/swift/proxy-server.conf it throws an exception: Could not bind to 0.0.0.0:8080 aster trying for 30 seconds.

edit flag offensive delete link more
0

answered 2014-01-02 13:29:57 -0500

esedmehmet gravatar image

proxy server ip that your virtual machine ip located on the proxy server.

edit flag offensive delete link more
0

answered 2014-01-03 09:47:26 -0500

fitros16 gravatar image

After following the instructions you gave me the same error still pops up in syslog and i get 503 server internal error. Any more ideas? Thanks

edit flag offensive delete link more
0

answered 2014-01-06 16:07:35 -0500

fitros16 gravatar image

Thanks Mehmet Hacısalihoğlu, that solved my question.

edit flag offensive delete link more
0

answered 2014-01-09 21:30:21 -0500

Can you please post the final config you used. I am also stuck on this problem and I have tried everything I can think of to get the memcached server and proxy-server to play nice together.

Thanks...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-29 11:45:21 -0500

Seen: 313 times

Last updated: Jan 11 '14