Ask Your Question
0

glance cache manage middleware not enabled

asked 2013-02-27 20:38:32 -0500

I'm trying to configure glance image cache with folsom, but glance-cache-manage list-cached keeps saying:

   Cache management middleware not enabled on host 0.0.0.0

I've configured this in glance-api.conf

[paste_deploy]
flavor = keystone+cachemanagement

With Essex I had no problems with the image cache.

Requesting the cached images list to v1 of the api via curl works ok, but not with v2:

$ curl --header "x-auth-token: $TOKEN" http://localhost:9292/v1/cached_images
{"cached_images": []}

$ curl --header "x-auth-token: $TOKEN" http://localhost:9292/v2/cached_images

<html> <head> <title>404 Not Found</title> </head> <body>

404 Not Found

The resource could not be found.

Note: there's a warning about "The 'glance.client' module is deprecated in favor of the 'glanceclient' module provided by python-glanceclient" Does this affects the issue?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-02-28 10:24:48 -0500

eglynn gravatar image

The cachemanagement middleware is hardcoded to expose its API as v1 only.

I've raised a bug for this:

https://bugs.launchpad.net/glance/+bug/1135537 (https://bugs.launchpad.net/glance/+bu...)

The deprecation warning is a known issue

https://bugs.launchpad.net/glance/+bug/1129445 (https://bugs.launchpad.net/glance/+bu...)

and is fixed here:

https://review.openstack.org/22305

edit flag offensive delete link more
0

answered 2013-02-28 13:21:48 -0500

We've been using mseknibilel's Folsom Install Guide guide to install, in which a script inserts a Keystone Image endpoint with v2 instead of v1, and that was the origin of the problem ( https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/blob/VLAN/2NICs/Keystone_Scripts/keystone_endpoints_basic.sh (https://github.com/mseknibilel/OpenSt...) )

We corrected the db record, restarted keystone, and the problem was solved.

Thank you.

edit flag offensive delete link more
0

answered 2013-05-06 13:40:58 -0500

To enable v1 endpoint for Glance, simply replace "v2" with "v1" in the 'extra' column of the 'endpoint' table in 'keystone' database -- the row to modify is the one with "id" equal to the "service_id" with 'image' type in the 'service' table.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-02-27 20:38:32 -0500

Seen: 116 times

Last updated: May 06 '13