Ask Your Question
0

Unable to see the attached volume in instance

asked 2013-04-11 13:26:40 -0600

shantha-kumar gravatar image

Hi,

I have single node openstack setup where ( compute + controller ) installed and running with all the required services.

I am able to create the volume using cinder and assign to instance but unable to see the attached volume inside the Virtual instances

################################ Services ################################ keystone start/running, process 7740 glance-api start/running, process 7742 glance-registry start/running, process 7744 mysql start/running, process 7770 quantum-server start/running, process 7829 quantum-dhcp-agent start/running, process 7846 quantum-metadata-agent start/running, process 7851 quantum-l3-agent start/running, process 7866 quantum-plugin-linuxbridge-agent start/running, process 7871 * Checking DNS forwarder and DHCP server dnsmasq * (dead, pid file exists) nova-api start/running, process 8073 nova-cert start/running, process 8084 nova-compute start/running, process 8096 nova-conductor start/running, process 8107 nova-consoleauth start/running, process 8122 nova-novncproxy start/running, process 8134 nova-scheduler start/running, process 8152 libvirt-bin start/running, process 2035 Apache2 is running (pid 8247). * memcached is running

#####################################

nova list +--------------------------------------+--------------+--------+-------------------+ | ID | Name | Status | Networks | +--------------------------------------+--------------+--------+-------------------+ | 3d34826f-480e-40bb-a2d5-9bd32b14ee05 | SB | ACTIVE | grzmrnw=50.50.1.4 | | 0583f7a7-ed02-43b6-b3c7-c1d7405426b5 | Testvm-ciros | ACTIVE | grzmrnw=50.50.1.3 | +--------------------------

cinder list +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+ | ID | Status | Display Name | Size | Volume Type | Bootable | Attached to | +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+ | 03d68746-6519-4f63-91d3-ba96603cf8cd | in-use | Testvol1 | 2 | None | false | 3d34826f-480e-40bb-a2d5-9bd32b14ee05 | +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+

Nova Compute log: #############

2013-04-12 07:17:40.957 8096 INFO nova.compute.manager [-] Updating host status 2013-04-12 07:17:42.408 AUDIT nova.compute.manager [req-2fd028df-8eda-48bd-a9ad-098074264bdb 4b106ff812b54472b8e2d3596524f730 fedfaa89548e41188c2dbd6f96d0de4a] [instance: 3d34826f-480e-40bb-a2d5-9bd32b14ee05] Attaching volume 03d68746-6519-4f63-91d3-ba96603cf8cd to /dev/vdb 2013-04-12 07:17:42.477 WARNING nova.virt.libvirt.utils [req-2fd028df-8eda-48bd-a9ad-098074264bdb 4b106ff812b54472b8e2d3596524f730 fedfaa89548e41188c2dbd6f96d0de4a] systool is not installed 2013-04-12 07:17:42.543 WARNING nova.virt.libvirt.utils [req-2fd028df-8eda-48bd-a9ad-098074264bdb 4b106ff812b54472b8e2d3596524f730 fedfaa89548e41188c2dbd6f96d0de4a] systool is not installed 2013-04-12 07:18:42.130 8096 AUDIT nova.compute.resource_tracker [-] Auditing locally available compute resources 2013-04-12 07:18:42.387 8096 AUDIT nova.compute.resource_tracker [-] Free ram (MB): 141987 2013-04-12 07:18:42.388 8096 AUDIT nova.compute.resource_tracker [-] Free disk (GB): -11 2013-04-12 07:18:42.388 8096 AUDIT nova.compute.resource_tracker [-] Free VCPUS: 22 2013-04-12 07:18:42.443 8096 INFO nova.compute.resource_tracker [-] Compute_service record updated for grzrc3:grzrc3

Virtual Machine: ############

Log into VM

iaasc@grzrc3:~$ ssh cirros@50.50.1.4 The authenticity of host '50.50.1.4 (50.50.1.4)' can't be established. RSA key fingerprint is 76:65:41:41:04:a0:2e:29:b4:8a:f5:11:a5:87:64:10. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added '50.50.1.4' (RSA) to the list of known hosts. cirros@50.50.1.4's password: $ $ fdisk -l $

Kindly help me on this.

edit retag flag offensive close merge delete

12 answers

Sort by » oldest newest most voted
0

answered 2013-05-17 06:16:01 -0600

In my environment, after installing sysfsutil tools on compute node, i saw warning message went away from nova-compute.log. However, fdisk -l on the launched instance still does not show the recently attached volume. Any ideas?

edit flag offensive delete link more
0

answered 2013-04-22 09:00:29 -0600

xinxin-shu gravatar image

i meet the same problem, but i have installed systool on all compute nodes, no error message can be found in compute and volume log.

edit flag offensive delete link more
0

answered 2013-05-09 18:01:28 -0600

shantha-kumar gravatar image

Shu, are you able to see the volume after your systool installation

edit flag offensive delete link more
0

answered 2013-04-12 12:02:39 -0600

drolfe gravatar image

I have the same error message on a single node setup of grizzly

edit flag offensive delete link more
0

answered 2013-04-12 12:08:43 -0600

shantha-kumar gravatar image

whats the cloud image you are using ?... Have uou find the route cause for this issue ?

edit flag offensive delete link more
0

answered 2013-04-16 04:18:53 -0600

drolfe gravatar image

Sorry I've since rebuild my dev cloud. If I were you I would be dugging the iscsi side of things.

Is it possible that the databases think the volume is connected but the iscsi connection has been dropped. i.e. have you rebooted your all in one node with the vm's and volumes still attached ?

edit flag offensive delete link more
0

answered 2013-04-16 07:55:42 -0600

drolfe gravatar image

As per https://answers.launchpad.net/cinder/+question/222896 (https://answers.launchpad.net/cinder/...)

""""" And this problem was solved after doing: "yum install sysfsutils" it seems "systool" was missing.. """""

but in ubuntu I'd try "sudo apt-get install sysfsutils" which should install systool for you

edit flag offensive delete link more
0

answered 2013-04-16 09:01:32 -0600

shantha-kumar gravatar image

Thanks for your response.

the Q/A https://answers.launchpad.net/cinder/+question/222896 (https://answers.launchpad.net/cinder/...) its related to attachment issue.

I'm getting the log as attachment successful and the horizon & CLI also says as volume attached to instance.

cinder list +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+ | ID | Status | Display Name | Size | Volume Type | Bootable | Attached to | +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+ | 03d68746-6519-4f63-91d3-ba96603cf8cd | in-use | Testvol1 | 2 | None | false | 3d34826f-480e-40bb-a2d5-9bd32b14ee05 | +--------------------------------------+--------+--------------+------+-------------+----------+--------------------------------------+

coming to systools installation. do I need to install in launched instance or in controller node..

bcoz my VM doesnt have external route and doesnt have internet connection.

edit flag offensive delete link more
0

answered 2013-04-18 00:26:16 -0600

drolfe gravatar image

I would try in install systools on the compute node, not the vm instance

edit flag offensive delete link more
0

answered 2013-05-17 06:30:11 -0600

xinxin-shu gravatar image

In my setup, my glance image does not load ‘acpiphp’ module to support hot plug, so after i loaded this module , everything is ok

-----Original Message----- From: bounces@canonical.com [mailto:bounces@canonical.com] On Behalf Of Hrushikesh Sent: Friday, May 17, 2013 2:17 PM To: Shu, Xinxin Subject: Re: [Question #226471]: Unable to see the attached volume in instance

Question #226471 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/226471 (https://answers.launchpad.net/nova/+q...)

Hrushikesh posted a new comment: In my environment, after installing sysfsutil tools on compute node, i saw warning message went away from nova-compute.log. However, fdisk -l on the launched instance still does not show the recently attached volume. Any ideas?


You received this question notification because you are a direct subscriber of the question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-11 13:26:40 -0600

Seen: 2,450 times

Last updated: May 17 '13