Ask Your Question
0

RemoteError: QuantumIOException Unable to connect to server

asked 2012-02-17 16:11:20 -0500

zshae gravatar image

My set up is 2 machines, one installs all openstack components (include compute node) + quantum + openvswitch, and the other machine installs only for compute node (nova-compute+nova-network+quantum client + openswitch).. That is there are two nova-compute nodes in my set up. The system works when the controller decide to boot the VM in the same )local) node. But there is error message when the controller decide to boot the VM in the other (remote) compute node. The 2 machines are connect to the same LAN. Here is the nova-compute log from the remote compute node. Any suggestion/solution would be very much appreciated.

2012-02-17 10:06:40,117 INFO nova.rpc [-] Connected to AMQP server on 9.2.156.10 7:5672 2012-02-17 10:06:40,118 DEBUG nova [-] Creating Consumer connection for Service compute from (pid=1457) start /usr/lib/pymodules/python2.7/nova/service.py:153 2012-02-17 10:07:40,143 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:09:42,008 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:11:43,685 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:13:45,547 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:15:47,191 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:17:49,107 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:19:51,019 INFO nova.compute.manager [-] Updating host status 2012-02-17 10:20:31,961 DEBUG nova.rpc [-] received {u'_context_roles': [u'Admin ', u'KeystoneServiceAdmin', u'Admin', u'KeystoneServiceAdmin'], u'_context_reque st_id': u'ebe28146-c068-416e-b69f-af47afed87ce', u'_context_read_deleted': False , u'args': {u'request_spec': {u'num_instances': 1, u'image': {u'status': u'activ e', u'name': u'ttylinux-uec-amd64-12.1_2.6.35-22_1', u'deleted': False, u'contai ner_format': u'ami', u'created_at': u'2012-02-09 14:38:51', u'disk_format': u'am i', u'updated_at': u'2012-02-09 14:38:51', u'properties': {u'kernel_id': u'10', u'owner': u'1', u'min_ram': u'0', u'ramdisk_id': u'11', u'min_disk': u'0'}, u'lo cation': u'file:///var/lib/glance/images/12', u'checksum': u'10047a119149e08fb20 6eea89832eee0', u'is_public': True, u'deleted_at': None, u'id': 12, u'size': 251 65824}, u'filter': None, u'instance_type': {u'rxtx_quota': 0, u'flavorid': 1, u' name': u'm1.tiny', u'deleted': False, u'created_at': None, u'updated_at': None, u'memory_mb': 512, u'vcpus': 1, u'rxtx_cap': 0, u'extra_specs': {}, u'swap': 0, u'deleted_at': None, u'id': 2, u'local_gb': 0}, u'blob': None, u'instance_proper ties': {u'vm_state': u'building', u'availability_zone': None, u'ramdisk_id': u'1 1', u'instance_type_id': 2, u'user_data': u'', u'vm_mode': None, u'reservation_i d': u'r-5f0a31sx', u'user_id': u'adminUser', u'display_description': u'x1', u'ke y_data': None, u'power_state': 0, u'project_id': u'1', u'metadata': {}, u'access _ip_v6': None, u'access_ip_v4': None, u'kernel_id': u'10', u'key_name': None, u' display_name': u'x1', u'config_drive_id': u'', u'local_gb': 0, u'architecture': None, u'locked': False, u'launch_time': u'2012-02-17T15:20:31Z', u'memory_mb': 5 12, u'vcpus ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-02-20 18:03:23 -0500

zshae gravatar image

The problem has been solved by removing the nova-network in the remove server. It works when there is only one nova-network running in the entire multiple host system.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-02-17 16:11:20 -0500

Seen: 10 times

Last updated: Feb 20 '12