Ask Your Question
0

SWauth issues in OpenStack Swift

asked 2011-11-07 01:41:56 -0500

konark-gill gravatar image

I have configured my Openstack swift for multi node installation. it was working fine. I wanted to add SWAUTH on top of it to use S3 APIs.

I have installed swauth from github.

  1. https://github.com/gholt/swauth.git .
  2. Ran command sudo python setup.py install.
  3. Made changes to my proxy-server.conf. It looks like this now.

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = catch_errors cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] use:egg:swauth#swauth set log_name = swauth super_admin_key = swauthkey default_swift_cluster = local#https://128.111.55.19:8080/v1

[filter:cache] use = egg:swift#memcache memcache_servers = 128.111.55.19:11211

[filter:catch_errors] use = egg:swift#catch_errors

  1. After this i run the commnad $swift-init proxy reload. It works fine.
  2. I run the command swauth-prep -K swauthkey.

The proxy server is stuck no response from it , no error nothing just stuck.

Please help me out as to wht could be the prob.

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2011-11-09 05:48:38 -0500

konark-gill gravatar image

Thanks a lot Marcelo

edit flag offensive delete link more
0

answered 2011-11-09 05:48:12 -0500

konark-gill gravatar image

Thanks Marcelo Martins, that solved my question.

edit flag offensive delete link more
0

answered 2012-01-09 05:03:11 -0500

How to setup https?

edit flag offensive delete link more
0

answered 2011-11-09 02:04:54 -0500

btorch gravatar image

Hi Konark,

Have you tried specifying the AUTH_URL to the command ? The default is HTTP and since you have HTTPS setup it will probably just hang.

Try: swauth-prep -K swauthkey -A https://127.0.0.1:8080/auth/

edit flag offensive delete link more
0

answered 2012-01-09 13:21:33 -0500

notmyname gravatar image

if the proxy server has the cert_file and key_file options defined, then it will use ssl

(however, I must point out that using ssl dorectly to the proxy is only a good idea for limited testing. Please use a load balancer or reverse proxy to terminate your ssl connections before the proxy.)

edit flag offensive delete link more
0

answered 2012-01-10 02:07:44 -0500

I've defined cer_file and key_file in proxy-server.conf. [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

my situation is just like Konarks'.According to what Marceb said,I need to setup https to solve this problm.But I couldn't find any way to setup https.

please tell me what command I should input to solve this problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-11-07 01:41:56 -0500

Seen: 82 times

Last updated: Jan 10 '12