Ask Your Question
0

How can I change quota of total volume size?

asked 2013-04-03 13:32:18 -0500

kj-tanaka gravatar image

Hi,

I'm trying to figure out how to change the quota of total volume size. I have one cinder volume which should be able to have about 2.5T total. It seems 1TB is defalt and I found out "osapi_max_limit = 1000" by "cinder-manage config list". I changed it to 2000, but no luck.

I would really appriciate if some of you can help me to figure this out.

Thanks in advance. Koji

edit retag flag offensive close merge delete

9 answers

Sort by ยป oldest newest most voted
0

answered 2013-04-03 19:50:42 -0500

zzs gravatar image

Can you try to modify the quota_gigabytes instead of osapi_max_limit.

edit flag offensive delete link more
0

answered 2013-04-03 13:53:18 -0500

kj-tanaka gravatar image

Ah... The command doesn't seem working. cinder quota-defaults keep showing 1000. Is it because I have keystone?

+-----------+-------+ | Property | Value | +-----------+-------+ | gigabytes | 1000 | | volumes | 10 | +-----------+-------+

Also, here's absolute-limits. cinder absolute-limits +-------------------------+-------+ | Name | Value | +-------------------------+-------+ | maxTotalVolumeGigabytes | 1000 | | maxTotalVolumes | 10 | +-------------------------+-------+

I would really appreciate any help. Thanks.

edit flag offensive delete link more
0

answered 2013-04-03 13:39:17 -0500

kj-tanaka gravatar image

I found out the command. Thanks.

cinder quota-update [--volumes <volumes>] [--gigabytes <gigabytes>] <tenant_id>

edit flag offensive delete link more
0

answered 2013-04-03 20:27:13 -0500

kj-tanaka gravatar image

Thank you Jason. I could change it to 2400. +-----------+-------+ | Property | Value | +-----------+-------+ | gigabytes | 2400 | | volumes | 10 | +-----------+-------+

But, I still get an "ERROR: VolumeSizeExceedsAvailableQuota". Do you know if there is another limitation, like a limit per user or something?

I already have a 900G volume, so I should be able to add a 1500G volume, but when I execute "cinder create 1400" or "nova volume-create 1400" I get this error. ERROR: VolumeSizeExceedsAvailableQuota: Requested volume exceeds allowed volume size quota (HTTP 413) (Request-ID: req-XXXXXXXXXXXXXXXXXXXXXXXXXXX)

edit flag offensive delete link more
0

answered 2013-04-04 03:03:57 -0500

zzs gravatar image

Can you sure you restart all the related services and the database data is updated?

edit flag offensive delete link more
0

answered 2013-04-04 19:55:27 -0500

kj-tanaka gravatar image

Yes, I restarted cinder-api, cinder-scheduler and cinder-volume several times. I tried to restart them and tried stop-start them, but no luck...

And, I see these outputs in --debug.

reply: 'HTTP/1.1 413 Request Entity Too Large\r\n' header: Retry-After: 0 header: Content-Length: 143 header: Content-Type: application/json header: X-Compute-Request-Id: req-2a3d4c6f-8b4d-4f36-949f-133436e630a2 header: Date: Thu, 04 Apr 2013 19:50:24 GMT DEBUG (shell:473) VolumeSizeExceedsAvailableQuota: Requested volume exceeds allowed volume size quota (HTTP 413) (Request-ID: req-2a3d4c6f-8b4d-4f36-949f-133436e630a2)

So, I'll look into database and see if I can find something...

Thanks

edit flag offensive delete link more
0

answered 2013-04-05 01:46:58 -0500

zzs gravatar image

How did you install the OpenStack and which version are you using?

edit flag offensive delete link more
0

answered 2013-04-05 03:17:18 -0500

kj-tanaka gravatar image

Jason, I could figure this out. My big mistake is this.

cinder quota-update --gigabytes 2500 cinder quota-show demo +-----------+-------+ | Property | Value | +-----------+-------+ | gigabytes | 2500 | | volumes | 10 | +-----------+-------+

Correct procedure is this.

cinder quota-update --gigabytes 2500 04b61dc833c3450eb15e95df3a9d0276 cinder quota-show demo +-----------+-------+ | Property | Value | +-----------+-------+ | gigabytes | 2500 | | volumes | 10 | +-----------+-------+

I think it would be great if cinder shows some error when user try to update some inexistent tenant-id, because on nova client, id and name work fine. At least, it should show some error... I hope.

edit flag offensive delete link more
0

answered 2013-04-05 03:21:00 -0500

kj-tanaka gravatar image

Well, I wrote wrong the previous comment.

Correct procedure is this. Tenant-id, not tenant name.

cinder quota-update --gigabytes 2500 04b61dc833c3450eb15e95df3a9d0276 cinder quota-show 04b61dc833c3450eb15e95df3a9d0276 +-----------+-------+ | Property | Value | +-----------+-------+ | gigabytes | 2500 | | volumes | 10 | +-----------+-------+

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-03 13:32:18 -0500

Seen: 1,930 times

Last updated: Apr 05 '13