Ask Your Question
0

internal server error

asked 2013-03-20 11:57:58 -0600

msarma00 gravatar image

Hi,

I installed openstack using devstack (single node install). And i am able to use the openstack dashboard. I could successfully create users as well, but i am not able to create networks. On submitting the 'create network' button, i got the following error :-

There was an error submitting the form. Please try again.

Also, i tried creating a network using the cli :-

quantum net-create net1

But it gave the following error:-

Request failed: internal server error while processing your request.

edit retag flag offensive close merge delete

20 answers

Sort by ยป oldest newest most voted
0

answered 2013-03-21 07:26:16 -0600

I've mistaken, it's not q-svc, but q-agt (quantum agent) is failing, so you need to check logs on corresponding tab (it should be near tab with q-svc)

edit flag offensive delete link more
0

answered 2013-03-21 07:32:25 -0600

msarma00 gravatar image

This is the localrc file:-

ADMIN_PASSWORD=password MYSQL_PASSWORD=password RABBIT_PASSWORD=password SERVICE_PASSWORD=password SERVICE_TOKEN=tokentoken disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-meta enable_service q-l3 enable_service quantum enable_service bigswitch_floodlight Q_PLUGIN=bigswitch_floodlight

edit flag offensive delete link more
0

answered 2013-03-21 07:34:57 -0600

msarma00 gravatar image

and there is no q-agt tab there. Am i doing something wrong?

edit flag offensive delete link more
0

answered 2013-03-21 07:57:41 -0600

salvatore-orlando gravatar image

The Big Switch plugin is a proxy to floodlight, which manages L2 & L3. Agents should be not running at all, as I think tney're not required.

Your agents are crashing because the plugin does not implement the RPC functions they call for synchronization (e.g.: sync-routers)

Try removing q-agt, and q-l3 from your localrc file.

Also, try and have a look at this document: http://www.openflowhub.org/display/floodlightcontroller/Install+Floodlight+and+OpenStack+on+Your+Own+Ubuntu+VM (http://www.openflowhub.org/display/fl...)

edit flag offensive delete link more
0

answered 2013-03-21 09:13:13 -0600

msarma00 gravatar image

Hi, i removed q-agt and q-l3 from localrc and then run stack.sh again. This time there was no error. But on trying to create a network, this was the error :-

\n \n\n

\n

\n You\'re seeing this error because you have DEBUG = True in\n your Django settings file. Change that to False, and Django\n will display a standard 404 page.\n

\n
\n</body>\n</html>\n' 2013-03-21 14:22:29 DEBUG [quantum.openstack.common.lockutils] Released file lock "rest_call" at /tmp/tmpWPEamV/bsn-rest_call for method "rest_call"... 2013-03-21 14:22:29 ERROR [quantum.plugins.bigswitch.plugin] ServerProxy: POST failure for servers: ('localhost', 80) 2013-03-21 14:22:29 ERROR [quantum.plugins.bigswitch.plugin] ServerProxy: POST failure for all servers: (('localhost', 80),) 2013-03-21 14:22:29 ERROR [quantum.plugins.bigswitch.plugin] QuantumRestProxyV2:Unable to create remote network: Error in REST call to remote network controller: None 2013-03-21 14:22:29 ERROR [quantum.api.v2.resource] create failed Traceback (most recent call last): File "/opt/stack/quantum/quantum/api/v2/resource.py", line 82, in resource result = method(request=request, *args) File "/opt/stack/quantum/quantum/api/v2/base.py", line 369, in create obj = obj_creator(request.context, *kwargs) File "/opt/stack/quantum/quantum/plugins/bigswitch/plugin.py", line 387, in create_network raise TypeError: exceptions must be old-style classes or derived from BaseException, not NoneType

edit flag offensive delete link more
0

answered 2013-03-21 12:02:12 -0600

msarma00 gravatar image

What's wrong with quantum now? Can anyone please help?

edit flag offensive delete link more
0

answered 2013-03-21 13:28:43 -0600

salvatore-orlando gravatar image

I am afraid this traceback is not really helpful (probably a little bug in the plugin, but I'd check this with Sumit Naiksatam first). Looking at the code it seems the floodlight proxy is returning an error code (anything not in 200-207 range), but this puzzles me too as in that case you should have more meesages in the log.

I am sorry but we need to hear from somebody more informed on the BSN plugin.

edit flag offensive delete link more
0

answered 2013-03-21 13:31:50 -0600

salvatore-orlando gravatar image

Sorry, but I missed a few bits in your log that clearly state the REST call is failing, Unfortunately, the log does not return the exact HTTP error code.

One thing to check would be the correctness of the information in /etc/quantum/plugins/bigswitch/restproxy.ini In particular the 'servers' and 'server_auth' parameters.

edit flag offensive delete link more
0

answered 2013-03-22 05:59:17 -0600

msarma00 gravatar image

This is the restproxy.ini file :-

Config file for quantum-proxy-plugin.

[DATABASE]

This line MUST be changed to actually run the plugin.

Example:

sql_connection = mysql://root:pass@127.0.0.1:3306/restproxy_quantum

Replace 127.0.0.1 above with the IP address of the database used by the

main quantum server. (Leave it as is if the database runs on this host.)

sql_connection = mysql://root:password@localhost/restproxy_quantum?charset=utf8

Database reconnection retry times - in event connectivity is lost

set to -1 implies an infinite retry count

sql_max_retries = 10

Database reconnection interval in seconds - if the initial connection to the

database fails

reconnect_interval = 2

Enable the use of eventlet's db_pool for MySQL. The flags sql_min_pool_size,

sql_max_pool_size and sql_idle_timeout are relevant only if this is enabled.

sql_dbpool_enable = False

Minimum number of SQL connections to keep open in a pool

sql_min_pool_size = 1

Maximum number of SQL connections to keep open in a pool

sql_max_pool_size = 5

Timeout in seconds before idle sql connections are reaped

sql_idle_timeout = 3600

[RESTPROXY] servertimeout = 10

All configuration for this plugin is in section '[restproxy]'

#

The following parameters are supported:

servers : <host:port>[,<host:port>]* (Error if not set)

server_auth : <username:password> (default: no auth)

server_ssl : True | False (default: False)

sync_data : True | False (default: False)

server_timeout : 10 (default: 10 seconds)

# servers=127.0.0.1:80 #server_auth=username:password #server_ssl=True #sync_data=True #server_timeout=10

edit flag offensive delete link more
0

answered 2013-03-22 06:25:19 -0600

Just wondering why [RESTPROXY] servers parameter is 127.0.0.1:80 Isn't this address used by Horizon dashboard? Is it possible that your floodlight service is trying to use the same address as Horizon? If so, you need to reconfigure either Horizon or floodlight service to use different ports.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-03-20 11:57:58 -0600

Seen: 2,646 times

Last updated: Mar 22 '13