Ask Your Question
0

Nova-compute over Slackware

asked 2011-12-21 04:12:33 -0500

sergio-troiano gravatar image

Hi folks,

I've got running my full openstack over one Ubuntu server, my question is: We use Slackware in our servers and i wanted to install only nova-compute over them

I looked for everywhere a guide or one "step by step" but nothing appeared...

In Slackware i downloaded nova-2011.3 and tried to install it, I came across with a lot of python errors like these:

nova-2011.3# python setup.py build WARNING: syntax errors in nova/virt/vmwareapi/vm_util.py: invalid syntax (vm_util.py, line 2) ERROR: Python module XenAPIPlugin not found ERROR: Python module pluginlib_nova not found ERROR: Python module xenstore not found ERROR: Python module simplejson not found ERROR: Python module migrate.versioning.shell not found ERROR: Python module glance not found ERROR: Python module glance.common not found ERROR: Python module paramiko not found ERROR: Python module migrate not found ERROR: Python module nose not found ERROR: Python module nose not found ERROR: Python module nose not found ERROR: Python module win32console not found ERROR: Python module pywintypes not found ERROR: Python module win32console not found ERROR: Python module glance not found ERROR: Python module boto_v6.ec2.connection not found ERROR: Python module kombu not found ERROR: Python module kombu.entity not found ERROR: Python module kombu.messaging not found ERROR: Python module kombu.connection not found ERROR: Python module memcache not found WARNING: syntax errors in nova/virt/vmwareapi/fake.py: invalid syntax (fake.py, line 2) ERROR: Python module bpython not found ERROR: Python module IPython not found WARNING: syntax errors in nova/tests/vmwareapi/db_fakes.py: invalid syntax (db_fakes.py, line 2) WARNING: syntax errors in nova/virt/vmwareapi_conn.py: invalid syntax (vmwareapi_conn.py, line 2) WARNING: syntax errors in nova/tests/vmwareapi/stubs.py: invalid syntax (stubs.py, line 2) WARNING: syntax errors in nova/virt/vmwareapi/vim.py: invalid syntax (vim.py, line 2) WARNING: syntax errors in nova/virt/vmwareapi/vmops.py: invalid syntax (vmops.py, line 2) ERROR: Python module XenAPIPlugin not found ERROR: Python module pluginlib_nova not found ERROR: Python module simplejson not found ERROR: Python module glance.common not found ERROR: Python module Cheetah not found ERROR: Python module simplejson not found ERROR: Python module novalib not found ERROR: Python module XenAPIPlugin not found ERROR: Python module pluginlib_nova not found ERROR: Python module simplejson not found WARNING: syntax errors in nova/tests/test_linux_net.py: invalid syntax (test_linux_net.py, line 2) ERROR: Python module novalib not found ERROR: Python module faults not found WARNING: syntax errors in nova/virt/vmwareapi/io_util.py: invalid syntax (io_util.py, line 2) /usr/lib64/python2.6/site-packages/python_distutils_extra-2.29-py2.6.egg/DistUtilsExtra/auto.py:323: DeprecationWarning: the sha module is deprecated; use the hashlib module instead mod = __import__(module) ERROR: Python module XenAPIPlugin not found ERROR: Python module pluginlib_nova not found ERROR: Python module Cheetah not found ERROR: Python module MySQLdb not found ERROR: Python module migrate not found ERROR: Python module nose.plugins.skip not found ERROR: Python module paramiko ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2011-12-21 17:36:31 -0500

sergio-troiano gravatar image

Finally i solved this issue reinstalling python in my slackware

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-12-21 04:12:33 -0500

Seen: 210 times

Last updated: Dec 21 '11