Ask Your Question
0

Update failed 503 service error - read all posts here and troubleshooting guide

asked 2011-01-09 23:16:46 -0500

EDIT: This issue is now resolved. The guide had a missing line for the proxy-server conf to allow the auth server to connect. It was added and now everything was working. Config:

[filter:auth] use = egg:swift#auth ssl = true ip = authserveriphere

I'm attempting to follow the guide located here: http://swift.openstack.org/howto_installmultinode.html (http://swift.openstack.org/howto_inst...)

To install a multi-node setup. 5 storage nodes(zg1-5) 1 proxy server(proxy) and 1 auth server(auth). I followed the guide to the section that instructs you to create swift admin account.

When I issue the following command(s), I receive "Update failed: 503 Service Unavailable" sudo -u swift swift-auth-add-user -K redacted -a system root testpass swift-auth-add-user -K redacted -a system root testpass

and a number of variations of that command

Notes: -Confirmed that all files/folders belong to swift user(including auth.db) -Read the posts here and the troubleshooting document in the wiki. -The internal IPs of the servers are: 192.168.143.47 (proxy) and 192.168.162.246 (auth)

Here is my auth-server.conf: [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key user = swift

[pipeline:main] pipeline = auth-server

[app:auth-server] use = egg:swift#auth default_cluster_url = https://192.168.143.47:8080/v1

Highly recommended to change this key to something else!

super_admin_key = redacted log_level = DEBUG

proxy-server.conf: [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache auth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true log_level = DEBUG

[filter:auth] use = egg:swift#auth ssl = true

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = 192.168.143.47:11211

I'm at a genuine loss for what to do, after spending a great deal of time soliciting help in #openstack. Thanks!

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2011-01-10 19:29:46 -0500

Or more exact, add a note to the fix the doc to the existing bug :-D

-----Original Message----- From: bounces@canonical.com [mailto:bounces@canonical.com] On Behalf Of John Dickinson Sent: Monday, January 10, 2011 1:06 PM To: jordan@openstack.org Subject: Re: [Question #140818]: Update failed 503 service error - read all posts here and troubleshooting guide

Question #140818 on OpenStack Object Storage (swift) changed: https://answers.launchpad.net/swift/+question/140818 (https://answers.launchpad.net/swift/+...)

Status: Open => Answered

John Dickinson proposed the following answer: This issue is now resolved. The guide had a missing line for the proxy- server conf to allow the auth server to connect. It was added and now everything was working. Config:

[filter:auth] use = egg:swift#auth ssl = true ip = authserveriphere


You received this question notification because you are an answer contact for OpenStack Object Storage (swift).

edit flag offensive delete link more
0

answered 2011-01-10 19:29:15 -0500

notmyname gravatar image

bug 700894 is already linked

edit flag offensive delete link more
0

answered 2011-01-10 19:06:12 -0500

notmyname gravatar image

This issue is now resolved. The guide had a missing line for the proxy-server conf to allow the auth server to connect. It was added and now everything was working. Config:

[filter:auth] use = egg:swift#auth ssl = true ip = authserveriphere

edit flag offensive delete link more
0

answered 2011-01-10 19:25:43 -0500

Nice find. I will file a bug against the documentation.

-----Original Message----- From: bounces@canonical.com [mailto:bounces@canonical.com] On Behalf Of John Dickinson Sent: Monday, January 10, 2011 1:06 PM To: jordan@openstack.org Subject: Re: [Question #140818]: Update failed 503 service error - read all posts here and troubleshooting guide

Question #140818 on OpenStack Object Storage (swift) changed: https://answers.launchpad.net/swift/+question/140818 (https://answers.launchpad.net/swift/+...)

Status: Open => Answered

John Dickinson proposed the following answer: This issue is now resolved. The guide had a missing line for the proxy- server conf to allow the auth server to connect. It was added and now everything was working. Config:

[filter:auth] use = egg:swift#auth ssl = true ip = authserveriphere


You received this question notification because you are an answer contact for OpenStack Object Storage (swift).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-01-09 23:16:46 -0500

Seen: 36 times

Last updated: Jan 10 '11