Ask Your Question
0

Savanna - Floating IP not able to access

asked 2013-09-23 10:36:23 -0500

sshimpi gravatar image

Hi Team,

I install RDO Grizzly version on my Desktop having following configuration -

OS - Redhat6.4 RAM - 12GB HDD - 300GB Network card - 1 [172.26.35.81/255.255.254.0] <- My network settings are set to DHCP.

Following is my current ifconfig command o/p -


[root@openstack ~]# ifconfig br100 Link encap:Ethernet HWaddr FE:16:3E:07:7B:BF
inet addr:192.168.32.1 Bcast:192.168.35.255 Mask:255.255.252.0 inet6 addr: fe80::7c4d:65ff:fe61:67c7/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:11702 errors:0 dropped:0 overruns:0 frame:0 TX packets:11382 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1371476 (1.3 MiB) TX bytes:1532115 (1.4 MiB)

eth0 Link encap:Ethernet HWaddr 00:16:41:3E:CD:2A
inet addr:172.26.35.81 Bcast:172.26.35.255 Mask:255.255.254.0 inet6 addr: fe80::216:41ff:fe3e:cd2a/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:263306 errors:0 dropped:0 overruns:0 frame:0 TX packets:33533 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:51806481 (49.4 MiB) TX bytes:6084462 (5.8 MiB) Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:4574550 errors:0 dropped:0 overruns:0 frame:0 TX packets:4574550 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:3576738626 (3.3 GiB) TX bytes:3576738626 (3.3 GiB)

virbr0 Link encap:Ethernet HWaddr 52:54:00:3A:88:7B
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

vnet0 Link encap:Ethernet HWaddr FE:16:3E:32:F0:CE
inet6 addr: fe80::fc16:3eff:fe32:f0ce/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:9929 errors:0 dropped:0 overruns:0 frame:0 TX packets:19127 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:1720736 (1.6 MiB) TX bytes:4390466 (4.1 MiB)

vnet1 Link encap:Ethernet HWaddr FE:16:3E:70:16:9D
inet6 addr: fe80::fc16:3eff:fe70:169d/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:6723 errors:0 dropped:0 overruns:0 frame:0 TX packets:3614 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:1501781 (1.4 MiB) TX bytes:627004 (612.3 KiB)

vnet2 Link encap:Ethernet HWaddr FE:16:3E:E8 ...

(more)
edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-23 12:35:45 -0500

mattf gravatar image

Make sure that the security group allows access to 50070 & 50030.

If that doesn't work, login via ssh and make sure the services are up.

If they are, there may be a routing issue.

What's the output of openstack-status and are you using nova-networking or neutron?

edit flag offensive delete link more
0

answered 2013-09-23 14:14:08 -0500

sshimpi gravatar image

As checked -

  1. 50070 & 50030 ports are running in netstat and listening
  2. ssh is working fine and namenode, datanode & mapred are working fine
  3. It seems to be network issue since -

i created network using following command -

nova floating-ip-bulk-create nova 172.26.35.0/23

But after assigning the floating ip to instance it still shows the network as "172.26.35.82/32".

It should take "172.26.35.0/23" !! Pls find the below o/p -

eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether 00:16:41:3e:cd:2a brd ff:ff:ff:ff:ff:ff
inet 172.26.35.81/23 brd 172.26.35.255 scope global eth0
inet 172.26.35.82/32 scope global eth0

Is there any mistake i am doing ?

edit flag offensive delete link more
0

answered 2013-09-23 11:58:52 -0500

sshimpi gravatar image

++++ -

I just tried to check o/p of #ipaddr command - and found that its taking subnet mask of 32 instead of 24 as i defined in nova command -

[root@openstack ~]# ip addr 1: lo: <loopback,up,lower_up> mtu 16436 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo inet 169.254.169.254/32 scope link lo inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP qlen 1000 link/ether 00:16:41:3e:cd:2a brd ff:ff:ff:ff:ff:ff inet 172.26.35.81/23 brd 172.26.35.255 scope global eth0 inet 172.26.35.82/32 scope global eth0 inet6 fe80::216:41ff:fe3e:cd2a/64 scope link valid_lft forever preferred_lft forever

edit flag offensive delete link more
0

answered 2013-09-24 13:17:52 -0500

mattf gravatar image

For ports 50070 & 50030, does the secgroup applied to the nodes allow access?

nova secgroup-list-rules default

+-------------+-----------+---------+-----------+--------------+ | IP Protocol | From Port | To Port | IP Range | Source Group | +-------------+-----------+---------+-----------+--------------+ | tcp | 22 | 22 | 0.0.0.0/0 | | +-------------+-----------+---------+-----------+--------------+

Above is an example of a group that allows ssh and does not allow 50070 | 50030.

You can go into Horizon and add rules for 50070 and 50030 if they are missing.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-23 10:36:23 -0500

Seen: 56 times

Last updated: Sep 24 '13