Ask Your Question
0

Can't login to Openstack Dashboard

asked 2013-05-27 03:25:38 -0600

ciaodarwin gravatar image

updated 2013-06-11 10:19:15 -0600

fifieldt gravatar image

Hello this is my frist question here (yaay :D)

I installed Openstack on my CentOS 6.3 Server... It still worked for 1 month... but since last week I can't login with the admin user.... I tried to reset the password with this command

curl -s -X POST -H "X-Auth-Token:999888777666" -d '{"changePassword": {"adminPass": "newPass"}}' http://localhost:8774/v1.1/openstack/servers/3/action__ (http://localhost:8774/v1.1/openstack/servers/3/action)

but i get this as answer:

401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

Authentication required

Can someone help me?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-05-27 04:54:04 -0600

Cloudie gravatar image

Go to your dashboard settings and see your password over there nad change it if you want to.. the path is /etc/openstack-dashboard/local_settings.py Hope that will resolve ur issue :)

edit flag offensive delete link more
0

answered 2013-05-28 03:47:54 -0600

jpichon gravatar image

I'm not sure why this started happening, but to reset the password you could use the keystone admin token, which you should be able to find in /etc/keystone/keystone.conf.

http://docs.openstack.org/developer/keystone/configuringservices.html#admin-token

I'm not familiar with the exact URL for changing password, but the one you're using calls to Nova so that's probably why it doesn't do anything nor recognise the keystone token.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-27 03:25:38 -0600

Seen: 8,950 times

Last updated: May 28 '13