Ask Your Question
0

An object with the specified identifier was not found.

asked 2012-09-30 20:52:44 -0500

qcjiang gravatar image

When I tried to add an image or list images, I always got this error,

root@myhostname:/var/log# glance --os_username=adminUser --os_password=supersecret --os_tenant=openstackDemo --os_region_name=RegionOne --os_auth_url=http://127.0.0.1:5000/v2.0 index Failed to show index. Got error: An object with the specified identifier was not found. Details: 404 Not Found

The resource could not be found.

Can you anyone suggest me how to debug/fix this problem? The error message is not useful since it doesn't spell out the identifier?

/var/log/glance# glance --version glance 2012.1.3-dev

Linux myhostname 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Thanks,

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2012-10-14 13:24:00 -0500

Hi,

I have the same glance version (glance 2012.1.3-dev) and have the same 404 error. Figured it was an endpoint problem. What endpoint for glance have you provided in keystone?

Thanks, Chandra

edit flag offensive delete link more
0

answered 2012-10-14 15:40:05 -0500

Fixed after correcting the endpoints.

edit flag offensive delete link more
0

answered 2012-09-30 22:08:06 -0500

qcjiang gravatar image

after creating correct endpoints. problem was solved.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-09-30 20:52:44 -0500

Seen: 90 times

Last updated: Oct 14 '12