Ask Your Question

Possible delay in Quantum GRE and flows

asked 2013-05-02 09:14:53 -0500

colo90 gravatar image

updated 2014-03-05 01:29:51 -0500

darragh-oreilly gravatar image

Hi All, i have a brand new install of Grizzly on Ubuntu 12.04 with network_type gre I have high RTT for the first packets when i'm trying to ping the VM My VM has a Private IP: natted on Public IP: When i try to reach public IP, i get this output :

PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=58 time=6546 ms
64 bytes from icmp_req=2 ttl=58 time=5546 ms
64 bytes from icmp_req=3 ttl=58 time=4546 ms
64 bytes from icmp_req=4 ttl=58 time=3546 ms
64 bytes from icmp_req=5 ttl=58 time=2546 ms
64 bytes from icmp_req=6 ttl=58 time=1546 ms
64 bytes from icmp_req=7 ttl=58 time=546 ms
64 bytes from icmp_req=8 ttl=58 time=2.52 ms
64 bytes from icmp_req=9 ttl=58 time=2.50 ms
64 bytes from icmp_req=10 ttl=58 time=2.73 ms
64 bytes from icmp_req=11 ttl=58 time=2.41 ms
64 bytes from icmp_req=12 ttl=58 time=2.67 ms

Seems that the flows are create with some delay. The output of the command : ovs-dpctl dump-flows br-int | grep 212.29.130 as soon as i start the ping is blank when ping start work the flows are created succesfull

ovs-dpctl dump-flows br-int | grep 212.29.130

in_port(80),eth(src=fa:16:3e:99:1b:4c,dst=fa:16:3e:da:15:4c),eth_type(0x0800),ipv4(src=,dst=,proto=1,tos=0,ttl=58,frag=no),icmp(type=8,code=0), packets:7, bytes:686, used:0.276s, actions:push_vlan(vid=11,pcp=0),65

in_port(65),eth(src=fa:16:3e:da:15:4c,dst=fa:16:3e:99:1b:4c),eth_type(0x8100),vlan(vid=11,pcp=0),encap(eth_type(0x0800),ipv4(src=,dst=,proto=1,tos=0,ttl=64,frag=no),icmp(type=0,code=0)), packets:1, bytes:98, used:0.276s, actions:pop_vlan,80

if i try to ping again the VM (when the flow is created) ping works properly, otherwise latency problems occurs again.

Am I doing something wrong?Can anyone help with this? if you need other information, don't hesitate to ask Thanks

edit retag flag offensive close merge delete

11 answers

Sort by ยป oldest newest most voted

answered 2013-05-02 14:41:22 -0500

darragh-oreilly gravatar image

just to confirm, the 1st ping request packet is reaching br-int quickly - ie it is not getting slowed down outside openstack/quantum and taking 6.5 seconds to reach the quantum router gateway?

edit flag offensive delete link more


Hello, we have exactly same issue. I tried to enable STP on br-int, but it didn't help. I found out, that we have port inconsistency between ovs config.db and real VM ports. Some ports which are in ovs config.db are not created. We have about 80 instances on 3 nodes. We see thousands of dropped messages in ovs-vswitchd.log each few seconds. Does anyone know, how to find out what messages are dropped?

kmadac gravatar imagekmadac ( 2014-03-04 13:56:52 -0500 )edit

I'm not sure. You could try clearing/reseting the local ovs db - not sure how, but shouldn't be too hard. Also the OP says a better CPU fixed it. Maybe have a look at the load from vswitchd. OVS v2 now has multithreaded support - that might help.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-05 01:37:55 -0500 )edit

Thanks for reply. Today I upgraded OVS to 1.10.2 and latency is gone.

kmadac gravatar imagekmadac ( 2014-03-05 10:16:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-05-02 09:14:53 -0500

Seen: 435 times

Last updated: Mar 05 '14