Ask Your Question
0

can't logon to dashboard with openstack-dashboard-2012.1-2.fc16.noarch.rpm

asked 2012-04-18 23:08:07 -0500

askstack gravatar image

Hi I am trying to follow this guide, http://fedoraproject.org/wiki/Getting_started_with_OpenStack_on_Fedora_17#Basic_Setup (http://fedoraproject.org/wiki/Getting...)

Yesterday I was able to setup a VM with a working dashboard with openstack-dashboard-2012.1-1.fc16.noarch . Today, I am trying to setup a physical machine but I can't login to dashboard. The only difference I can find it the dashboard rpm is a newer version, openstack-dashboard-2012.1-2.fc16.noarch.

On the working VM, /var/log/keystone/keystone.log would show activities for the dashboard login page. On the non working physical machine, the log doesn't change for dashboard.

Settings on the non-working machine.

keystone service-list

| 47b753dbfa5c4794afd604eac3b771d8 | horizon | dashboard | OpenStack Dashboard

/etc/openstack-dashboard/local_settings

import os from django.utils.translation import ugettext_lazy as _ DEBUG = True TEMPLATE_DEBUG = DEBUG PROD = False USE_SSL = False SECRET_KEY = 'elj1IWiLoWHgcyYxFVLj7cM5rGOOxWl0' LOCAL_PATH = os.path.dirname(os.path.abspath(__file__)) CACHE_BACKEND = 'locmem://' EMAIL_BACKEND = 'django.core.mail.backends.console.EmailBackend' OPENSTACK_HOST = "127.0.0.1" OPENSTACK_KEYSTONE_URL = "http://%s:5000/v2.0" % OPENSTACK_HOST OPENSTACK_KEYSTONE_DEFAULT_ROLE = "Member" OPENSTACK_KEYSTONE_BACKEND = { 'name': 'native', 'can_edit_user': True } API_RESULT_LIMIT = 1000 LOGGING = { 'version': 1, # When set to True this will disable all logging except # for loggers specified in this configuration dictionary. Note that # if nothing is specified here and disable_existing_loggers is True, # django.db.backends will still log unless it is disabled explicitly. 'disable_existing_loggers': False, 'handlers': { 'null': { 'level': 'DEBUG', 'class': 'django.utils.log.NullHandler', }, 'console': { # Set the level to "DEBUG" for verbose output logging. 'level': 'INFO', 'class': 'logging.StreamHandler', }, }, 'loggers': { # Logging from django.db.backends is VERY verbose, send to null # by default. 'django.db.backends': { 'handlers': ['null'], 'propagate': False, }, 'horizon': { 'handlers': ['console'], 'propagate': False, }, 'novaclient': { 'handlers': ['console'], 'propagate': False, }, 'keystoneclient': { 'handlers': ['console'], 'propagate': False, }, 'nose.plugins.manager': { 'handlers': ['console'], 'propagate': False, } } }

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-04-19 14:40:08 -0500

askstack gravatar image

I set selinux to be permissive on the VM but forgot to do the same on the physical machine. The rpms are fine. I need to pay more attention for /var/log/audit/audit.log for denied messages.

http://fedoraproject.org/wiki/Getting_started_with_OpenStack_on_Fedora_17#Configure_the_OpenStack_Dashboard (http://fedoraproject.org/wiki/Getting...)

If selinux is enabled, you will have to allow httpd to access other network services (the dashboard talks to the http API of the other OpenStack services)

sudo setsebool -P httpd_can_network_connect=on

edit flag offensive delete link more
0

answered 2012-04-26 13:47:46 -0500

: - ) askstack . thank you very much

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-18 23:08:07 -0500

Seen: 28 times

Last updated: Apr 26 '12