stack.sh failing with ImproperlyConfigured("You haven't set the database ENGINE setting yet.")

asked 2012-04-02 20:33:42 -0600

swoo gravatar image

I downloaded the devstack today. When I run the stack.sh script I'm getting the following error:

Using /usr/local/lib/python2.7/dist-packages Searching for greenlet==0.3.1 Best match: greenlet 0.3.1 Adding greenlet 0.3.1 to easy-install.pth file

Using /usr/lib/python2.7/dist-packages Searching for nose==1.0.0 Best match: nose 1.0.0 nose 1.0.0 is already the active version in easy-install.pth Installing nosetests script to /usr/local/bin Installing nosetests-2.7 script to /usr/local/bin

Using /usr/lib/pymodules/python2.7 Finished processing dependencies for horizon==2012.2 + is_service_enabled quantum + services=quantum + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,quantum, ]] + [[ quantum == \n\o\v\a ]] + [[ quantum == \g\l\a\n\c\e ]] + [[ quantum == \q\u\a\n\t\u\m ]] + [[ g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit =~ q- ]] + return 1 + is_service_enabled q-svc + services=q-svc + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,q-svc, ]] + [[ q-svc == \n\o\v\a ]] + [[ q-svc == \g\l\a\n\c\e ]] + [[ q-svc == \q\u\a\n\t\u\m ]] + return 1 + is_service_enabled m-svc + services=m-svc + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,m-svc, ]] + [[ m-svc == \n\o\v\a ]] + [[ m-svc == \g\l\a\n\c\e ]] + [[ m-svc == \q\u\a\n\t\u\m ]] + return 1 + is_service_enabled melange + services=melange + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,melange, ]] + [[ melange == \n\o\v\a ]] + [[ melange == \g\l\a\n\c\e ]] + [[ melange == \q\u\a\n\t\u\m ]] + return 1 + [[ False != \F\a\l\s\e ]] + is_service_enabled rabbit + services=rabbit + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,rabbit, ]] + return 0 ++ mktemp + tfile=/tmp/tmp.9NLcgkHURf + apt_get install rabbitmq-server + cat /tmp/tmp.9NLcgkHURf + [[ False = \T\r\u\e ]] + [[ -z install rabbitmq-server ]] + local sudo=sudo ++ id -u + [[ 1000 = \0 ]] + sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes install rabbitmq-server Reading package lists... Building dependency tree... Reading state information... rabbitmq-server is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. + rm -f /tmp/tmp.9NLcgkHURf + sudo rabbitmqctl change_password guest mybunny Changing password for user "guest" ... ...done. + is_service_enabled mysql + services=mysql + for service in '${services}' + [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,mysql,rabbit, =~ ,mysql, ]] + return 0 + cat + sudo debconf-set-selections + [[ ! -e /home/localadmin/.my.cnf ]] + apt_get install mysql-server + [[ False = \T\r\u\e ]] + [[ -z install mysql-server ]] + local sudo=sudo ++ id -u + [[ 1000 = \0 ]] + sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes install mysql-server Reading package lists... Building dependency tree... Reading state information ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-04-03 18:36:28 -0600

swoo gravatar image

I did a new download today and the problem is gone.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-02 20:33:42 -0600

Seen: 47 times

Last updated: Apr 03 '12