Ask Your Question
0

Linux bridge leaves artifacts when all ports are deleted from network

asked 2012-04-30 10:50:37 -0500

garyk gravatar image

When all ports are removed from the network the linux bridge still leaves the bridge. This is only deleted when the network is deleted. Is this by design or a bug? Maybe it would be best if the bridge was deleted when the last port is deleted from the bridge

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-04-30 15:43:39 -0500

garyk gravatar image

Thanks Sumit Naiksatam, that solved my question.

edit flag offensive delete link more
0

answered 2012-04-30 15:33:19 -0500

Hi Gary, This is currently by design. Note that there is additional gateway related configuration that is performed on the nova-network side, and which gets triggered only when the network is created. If the bridge is deleted, this configuration will be lost, and will not be available when the same network has to be used again. Hence I did not do this optimization.

Once all the L3 configuration is moved to Quantum (and we are not using nova-network any more), one can consider performing this optimization.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-30 10:50:37 -0500

Seen: 8 times

Last updated: Apr 30 '12