Ask Your Question
0

Problem nova-compute service

asked 2013-05-29 15:13:46 -0500

nassim-kaabache gravatar image

Hi,

I install a compute controller that it s also a compute node, and I want to add a compute node on my network. I install only nova-common, nova-compute and nova-api. It s the 2012.2.3 for the compute node (debian) because my controller is 2012.2.2 version. It s the only version I find to be in folsom for both.

The thing is I install on my node compute nova-compute and nova-api (I check with dpkg --get-selections | grep nova) but the command line "service nova-compute start or nova -api start doesn't work, it says that it doesn't recognized the service. So I don't understand where is the problem, when I check nova-manage service list on both (controller and node) there is only controller host. Have you any reason why it doesnt work ?

thanks

Nassim

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-05-30 14:15:32 -0500

nassim-kaabache gravatar image

I find the problem but not the reason why. The service wasn't nova-compute but nova-compute.dkpg-new. It can be a problem from dpkg when we want to change nova version, I don't know if this problem exists when it s install with apt-get install but it can be a tricky problem...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-29 15:13:46 -0500

Seen: 38 times

Last updated: May 30 '13