fixed_range='' results in critical error when starting nova-network

asked 2013-05-23 12:53:20 -0600

nexen gravatar image

updated 2013-05-24 17:26:45 -0600

smaffulli gravatar image

The error is resolved if I set fixed_range manually, i.e. fixed_range=

VM launching via Horizon and guest networking is fully operational with the above fix.

Similar error but different cause, here

I am using FlatDHCP networking between two Openstack nodes running the Folsom release (from EPEL) on a base installation of Scientific Linux 6.4. I followed the guide from Red Hat, here and for the network setup, the Openstack Compute manual, and Mirantis blog post (suggested in the Compute manual).

Controller node (Keystone, Nova, Glance, Horizon) "sl1":
Compute only node "compute1":

Iptables disabled (service iptables stop on both nodes).

Every service except nova-network seems to be operational, judging from openstack-status and service --status-all | grep openstack.

nova.conf snippet on the controller node:

network_manager =
flat_interface = eth2
public_interface = eth1
my_ip =
flat_network_bridge = br100
flat_injected = False

nova.conf snippet on the compute only node:

network_manager =
flat_interface = eth1
public_interface = eth0
my_ip =
#fixed_range =
#fixed_range = ''
flat_network_bridge = br100
flat_injected = False

s3_host =
ec2_host =
qpid_hostname =
metadata_host =
ec2_dmz_host =

nova-network.log (identical on both nodes):

2013-05-22 16:21:17 18884 AUDIT nova.service [-] Starting network node (version 2012.2.3-1.el6)
2013-05-22 16:21:22 18884 CRITICAL nova [-] Unexpected error while running command.
Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iptables-restore -c
Exit code: 2
Stdout: ''
Stderr: "Bad argument `SNAT'\nError occurred at line: 27\nTry `iptables-restore -h' or 'iptables-restore --help' for more information.\n"

Any suggestions on what might be the issue would be much appreciated! Thanks.

edit retag flag offensive close merge delete


I read "The error is resolved if I set fixed_range manually, i.e. fixed_range=": is this the solution to the question?

smaffulli gravatar imagesmaffulli ( 2013-07-26 17:14:52 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2013-09-23 03:53:53 -0600

The fixed_range option is deprecated in Grizzly release and should be set to fixed_range=''. You said that you are using Folsom, so it must be set to work correctly.

edit flag offensive delete link more

answered 2013-09-23 04:23:02 -0600

ArKam gravatar image

I had the exact same issue, and it came from the My_IP variable that was not used on the configuration file, just delete it ;-)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2013-05-23 12:53:20 -0600

Seen: 794 times

Last updated: Sep 23 '13