Ask Your Question
0

On Red Hat 6 RHEL, nova-manage create network fails due to no bridge interface

asked 2011-10-13 00:30:20 -0500

robpneff gravatar image

I installed Diablo on RHEL6.0. All of the services start correctly. However, the create network command fails.

Why is OpenStack not seeing ifcfg-br100 and failing to create a network?

$nova-manage network create 192.168.0.0/24 1 256 Command failed, please check log for info The nova-manage.log reads:
nova: --bridge interface is required to create a network

However, when I look at /etc/sysconfig/network-scripts, I see ifcfg-br100, ifcfg-eth0, ifcfg-eth1

$sudo service network restart Bringing up interface eth0: [ OK ] Bringing up interface eth1: [ OK ] Bringing up interface br100: [ OK ]

ifcfg-br100

DEVICE=br100 NM_CONTROLLED="no" ONBOOT=yes TYPE=Bridge BOOTPROTO=static IPADDR=10.134.148.17 PREFIX=22 NETMASK=255.255.252.0 GATEWAY=10.134.148.1 DNS1=10.134.14.60 DNS2=10.10.8.132 DEFROUTE=yes IPV4_FAILURE_FATAL=yes IPV6INIT=no

ifcfg-eth0

DEVICE="eth0" TYPE=Ethernet HWADDR=00:21:CC:60:FB:4A ONBOOT=yes NM_CONTROLLED=no BRIDGE=br100 NAME="Static Bridged eth0" UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03

ifcfg-eth1

DEVICE="eth1" HWADDR="00:21:CC:60:FB:72" NM_CONTROLLED="no" ONBOOT="yes" IPADDR=192.168.3.1 NETMASK=255.255.0.0 BROADCAST=192.168.255.255

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2011-10-14 21:57:52 -0500

robpneff gravatar image

THANK YOU both Yaguang and Vish for replying. I tried both of your suggestions, but I'm still seeing the same error in the log. Any more suggestions?

Vish, I added the line below and restarted all of the nova services. --flat_network_bridge=br100 to my nova.conf file below.

CURRENT NOVA.CONF --verbose=false --ec2_url=http://10.134.148.17:8773/services/Cloud --fixed_range=192.168.0.0/16 --s3_host=10.134.148.17 --cc_host=10.134.148.17 --rabbit_host=10.134.148.17 --sql_connection=mysql://XXXXXX:XXXXXX@10.134.148.17/XXXXXX --glance_port=9292 --glance_host=10.134.148.17 --use_s3=true --libvirt_type=kvm --use_syslog=false --node_availability_zone=nova --logdir=/var/log/nova --logging_context_format_string=%(asctime)s %(name)s: %(levelname)s [%(request_id)s %(user)s %(project)s] %(message)s --logging_default_format_string=%(asctime)s %(name)s: %(message)s --logging_debug_format_suffix= --use_cow_images=true --auth_driver=nova.auth.dbdriver.DbDriver --network_manager=nova.network.manager.VlanManager --scheduler_driver=nova.scheduler.zone.ZoneScheduler --image_service=nova.image.glance.GlanceImageService --use_ipv6=false --ca_path=/var/lib/nova/CA --keys_path=/var/lib/nova/keys --images_path=/var/lib/nova/images --buckets_path=/var/lib/nova/buckets --instances_path=/var/lib/nova/instances --networks_path=/var/lib/nova/networks --dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --flat_network_bridge=br100 --injected_network_template=/usr/share/nova/interfaces.rhel.template --libvirt_xml_template=/usr/share/nova/libvirt.xml.template --vpn_client_template=/usr/share/nova/client.ovpn.template --credentials_template=/usr/share/nova/novarc.template --state_path=/var/lib/nova --lock_path=/var/lib/nova/tmp --vnc_enabled=true --vncproxy_url=http://127.0.0.1:6080 --vncserver_host=0.0.0.0 --vnc_token_ttl=300

edit flag offensive delete link more
0

answered 2011-10-18 17:44:39 -0500

robpneff gravatar image

The error message is incorrect. I attached the bug for this.

My mistake was having VlanManager.

--network_manager=nova.network.manager.VlanManager

This fixed the problem: --network_manager=nova.network.manager.FlatManager --flat_network_bridge=br100

edit flag offensive delete link more
0

answered 2011-10-13 02:16:19 -0500

heut2008 gravatar image

you may need to add a param such as nova-manage network create mynet 192.168.0.0/24 1 256

edit flag offensive delete link more
0

answered 2011-10-13 04:09:22 -0500

vishvananda gravatar image

You need to specify bridge interface or set the flag --flat_network_interface It doesn't default to br100 anymore. On Oct 12, 2011 5:30 PM, "Rob Neff" question174086@answers.launchpad.net wrote:

New question #174086 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

I installed Diablo on RHEL6.0. All of the services start correctly. However, the create network command fails.

Why is OpenStack not seeing ifcfg-br100 and failing to create a network?

$nova-manage network create 192.168.0.0/24 1 256 Command failed, please check log for info The nova-manage.log reads: nova: --bridge interface is required to create a network

However, when I look at /etc/sysconfig/network-scripts, I see ifcfg-br100, ifcfg-eth0, ifcfg-eth1

$sudo service network restart Bringing up interface eth0: [ OK ] Bringing up interface eth1: [ OK ] Bringing up interface br100: [ OK ]

ifcfg-br100

DEVICE=br100 NM_CONTROLLED="no" ONBOOT=yes TYPE=Bridge BOOTPROTO=static IPADDR=10.134.148.17 PREFIX=22 NETMASK=255.255.252.0 GATEWAY=10.134.148.1 DNS1=10.134.14.60 DNS2=10.10.8.132 DEFROUTE=yes IPV4_FAILURE_FATAL=yes IPV6INIT=no

ifcfg-eth0

DEVICE="eth0" TYPE=Ethernet HWADDR=00:21:CC:60:FB:4A ONBOOT=yes NM_CONTROLLED=no BRIDGE=br100 NAME="Static Bridged eth0" UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03

ifcfg-eth1

DEVICE="eth1" HWADDR="00:21:CC:60:FB:72" NM_CONTROLLED="no" ONBOOT="yes" IPADDR=192.168.3.1 NETMASK=255.255.0.0 BROADCAST=192.168.255.255


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-12-23 01:21:34 -0500

I added the following which gave me the same error.

--flat_network_interface=br100 --bridge_interface=br100

Added the following and was able to create networks:

--vlan_interface=eth1

From page 60 of os-compute-adminguide-cactus.pdf section 7.3.3 states:

Please note that currently eth0 is hardcoded as the vlan_interface in the default flags. If you need to attach your bridges to a device other than eth0, you will need to add following flag to /etc/nova/nova.conf: --vlan_interface=eth1

can anyone else verify their br100 bridge is to interface eth1? This error is ambiguous overall.

Bryan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-10-13 00:30:20 -0500

Seen: 106 times

Last updated: Dec 23 '11