Ask Your Question
0

keystone swift intergration problem: object-store endpoint

asked 2012-04-24 17:33:22 -0500

askstack gravatar image

Hello I am installing openstack on fedora 16 with these RPMs.

openstack-keystone-2012.1-1.fc16.noarch openstack-dashboard-2012.1-2.fc16.noarch openstack-swift-1.4.6-2.fc16.noarch openstack-swift-object-1.4.6-2.fc16.noarch openstack-glance-2012.1-3.fc16.noarch openstack-swift-proxy-1.4.6-2.fc16.noarch openstack-swift-container-1.4.6-2.fc16.noarch openstack-nova-2012.1-1.fc16.noarch openstack-swift-account-1.4.6-2.fc16.noarch

I think I have keystone configured correctly.

[root@core01 swift]# curl -s -H 'Content-type: application/json' -d '{"auth": {"tenantName": "zone0", "passwordCredentials": {"username": "swift", "password": "verybadpass"}}}' http://127.0.0.1:35357/v2.0/tokens | python -mjson.tool

    "token": {
        "expires": "2012-04-25T15:59:15Z", 
        "id": "7fc47f28bd614f3bb64e1868ff856996", 
        "tenant": {
            "description": null, 
            "enabled": true, 
            "id": "e8517a58d2e9498fa695d34ba9a09073", 
            "name": "zone0"
        }
    }, 
    "user": {
        "id": "1601e902c4024993a163538869aa99ed", 
        "name": "swift", 
        "roles": [
            {
                "id": "bc3b434dea5e450c8f7c66315104df58", 
                "name": "Member"
            }, 
            {
                "id": "93e6a98b64d04e7da02c9ae476319fec", 
                "name": "admin"
            }
        ], 
        "roles_links": [], 
        "username": "swift"
    }
}

[root@core01 swift]# curl -s -H 'X-Auth-Token:7fc47f28bd614f3bb64e1868ff856996' http://127.0.0.1:35357/v2.0/tokens/7fc47f28bd614f3bb64e1868ff856996 (http://127.0.0.1:35357/v2.0/tokens/7f...) | python -mjson.tool { "access": { "token": { "expires": "2012-04-25T15:59:15Z", "id": "7fc47f28bd614f3bb64e1868ff856996", "tenant": { "description": null, "enabled": true, "id": "e8517a58d2e9498fa695d34ba9a09073", "name": "zone0" } }, "user": { "id": "1601e902c4024993a163538869aa99ed", "name": "swift", "roles": [ { "id": "bc3b434dea5e450c8f7c66315104df58", "name": "Member" }, { "id": "93e6a98b64d04e7da02c9ae476319fec", "name": "admin" } ], "roles_links": [], "username": "swift" } } }

[root@core01 swift]# swift -v -V 2.0 -A http://127.0.0.1:5000/v2.0/ -U zone0:swift -K verybadpass stat There is no object-store endpoint on this auth server.

[root@core01 swift]# cat /etc/swift/proxy-server.conf [DEFAULT] bind_port = 8080 workers = 8 user = swift log_facility = LOG_LOCAL1

[pipeline:main] pipeline = catch_errors healthcheck cache swiftauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true account_autocreate = true set log_name = swift-proxy-server set log_facility = LOG_LOCAL1 set log_level = DEBUG set access_log_name = swift-proxy-server set access_log_facility = LOG_LOCAL1 set access_log_level = DEBUG set log_headers = True

[filter:healthcheck] use = egg:swift#healthcheck

[filter:catch_errors] use = egg:swift#catch_errors

[filter:cache] use = egg:swift#memcache set log_name = cache

[filter:swiftauth] paste.filter_factory = keystone.middleware.swift_auth:filter_factory operator_roles = admin, SwiftOperator is_admin = true

[filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = 127.0.0.1 service_port = 5000 auth_protocol = http auth_host = 127.0.0.1 auth_port = 35357 admin_tenant_name = service admin_user = swift admin_password = verybadpasswd delay_auth_decision = 0

any help is greatly appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-04-26 18:46:09 -0500

askstack gravatar image

nice people on openstack IRC channel told me I need to create a endpoint.

keystone endpoint-create --region RegionOne --service_id=f3ad90256d2b4c2d881ff91ab733d409 --publicurl 'http://127.0.0.1:8080/v1/AUTH_c67bdd38c56f4ca0956cf5ca8d47ff41' --adminurl 'http://127.0.0.1:8080/' --internalurl 'http://127.0.0.1:8080'

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-24 17:33:22 -0500

Seen: 16 times

Last updated: Apr 26 '12