Ask Your Question
0

OpenStack Dashboard (Horizon) Fails to Allow Log In

asked 2013-04-07 05:09:22 -0600

elithrar gravatar image

I cannot log in to the OpenStack Dashboard; attempting to do so results in a re-direct back to the log-in page. Running Folsom on Ubuntu Server 12.10.

Entering the wrong details will throw an "incorrect user/pass" error; the correct details will show nothing.

I cannot see any issues in /var/log/nova-api.log or similar.

My apache2/error.log does show some 401's relating to Cinder, but I'm not sure if these are a red herring: gist.github.com/elithrar/15913c5196c744777083

nova-manage service list shows smiley faces, and keystone service-list shows the expected services with no errors.

I'd appreciate some advice here—a Google hasn't helped.

edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
1

answered 2013-04-08 06:36:36 -0600

jpichon gravatar image

Until Grizzly, Horizon would log you out if receiving a 401/403 not authorized error [0] -- so this is probably what's happening there, you are getting logged out before the page has finished loading. You should investigate what is causing the Cinder error.

[0] See the release notes at docs.openstack.org/developer/horizon/releases/2013_1.html#not-authorized-being-logged-out

edit flag offensive delete link more

Comments

This fixed it. I rectified the 401's (caused by incorrect credentials in /etc/cinder/api-paste.ini) and restarted the cinder processes.

elithrar gravatar imageelithrar ( 2013-04-12 07:31:14 -0600 )edit
1

answered 2013-04-07 05:40:56 -0600

tim-bell gravatar image

We've seen this at CERN with Folsom. The workaround was to restart keystone.

Root cause was not understood and we'll be retesting with Grizzly to see if the problem occurs there.

edit flag offensive delete link more

Comments

Thanks for the response. Restarting keystone and/or the server doesn't seem to resolve the issue unfortunately. Keystone's own logs have nothing, either, which hasn't been helpful.

elithrar gravatar imageelithrar ( 2013-04-07 06:12:32 -0600 )edit
1

answered 2013-04-07 08:58:38 -0600

updated 2013-04-07 11:45:00 -0600

I already saw this and I same as you didn't know how to fix it, so I deleted keystone database and recreated all users, roles, services, etc. That is probably something related to keystone.

Did you try to run sync: keystone-manage db_sync

edit flag offensive delete link more

Comments

I have, with no luck. I'm trying to avoid dropping the keystone DB if possible.

elithrar gravatar imageelithrar ( 2013-04-09 02:21:03 -0600 )edit
0

answered 2013-05-14 08:27:33 -0600

hey i need help i get error on my openstack dashboard...i used the scripted method to install openstack through devstack.com. it had only 2 commands i typed it down,the rest it did every installation by its own. when the installation was completed i wrote my ip address on another system,typed the user id and p.w,it opened,in other words it worked,yet when i rebooted the system where i installed openstack,i started giving errors.my user id and p.w were not allowed...i need help please.. is there somthing i left behind?? please guide me.. ill be very thankful

edit flag offensive delete link more

Comments

Hey hassaan -- you should open a new question describing your issue, you're more likely to get answers this way. Make sure to include the error messages you're getting and any stack trace you can see in the logs.

jpichon gravatar imagejpichon ( 2013-05-27 04:35:04 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-07 05:09:22 -0600

Seen: 2,430 times

Last updated: May 14 '13