Ask Your Question
0

mismatch in documentation

asked 2011-04-20 09:35:30 -0600

amylee gravatar image

This probably doesn't belong here, but I thought it's worth to document this somewhere.

According to this page in the documentation: http://docs.openstack.org/cactus/openstack-compute/admin/content/setting-up-sql-database-mysql.html (http://docs.openstack.org/cactus/open...)

The mysql root user password is set to nova, but privileges for the nova database usage is given to the "nova" user, who has the password "notnova"

From this page: http://docs.openstack.org/cactus/openstack-compute/admin/content/setting-flags-in-nova-conf-file.html (http://docs.openstack.org/cactus/open...)

it seems like you should use the 'root' user with the 'nova' password in the conf file... it should probably be the 'nova' user with the 'notnova' password. at least only this way it worked for me. you could probably also give the root user privileges for the nova db... anyways, it would probably be more helpful to have that information in the documentation.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2011-08-19 13:34:07 -0600

Looks like this question is answered. Please reopen if not.

edit flag offensive delete link more
0

answered 2011-04-20 14:55:25 -0600

annegentle gravatar image

Thank you for reporting this, Amy. I had made the change to a nova/notnova MySQL user yesterday and hadn't discovered where else the doc was affected, so I appreciate you pointing this out. I turned it into a bug and fixed the bug.

You can also comment directly on the documentation page if you prefer. Really, what you did is fine too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-20 09:35:30 -0600

Seen: 7 times

Last updated: Aug 19 '11