Ask Your Question
1

Trying to install compute node inside ESXi

asked 2013-05-22 17:52:18 -0500

vpaul gravatar image

updated 2013-07-08 12:36:18 -0500

Jobin gravatar image

Hi there,

I'm trying to install a test environment on ESXi 5.0 server(controller and node, grizzly release). I've sorted all VT/ESXi related issues and able to start cirros VM with qemu like:

$ kvm -name "TEST" -M pc-0.12 -m 512 -cpu qemu64 cirros-0.3.1-x86_64-disk.img -vga cirrus -vnc 127.0.0.1:0

However, when I'm trying to launch an instance via nova boot or dashboard VM goes to error state with libvirtError: internal error only 1 graphics device is supported error. I've tried both libvirt_type=qemu/kvm; using Debian Wheezy if it makes any sense.

nova.conf - on the compute node.

[DEFAULT]
sql_connection=mysql://nova:password@192.168.1.30/nova
force_config_drive=true

allow_admin_api=true
api_paste_config=/etc/nova/api-paste.ini
my_ip = 192.168.1.27
ec2_private_dns_show_ip=True
logdir=/var/log/nova
debug=true
state_path=/var/lib/nova
lock_path=/var/lock/nova
rootwrap_config=/etc/nova/rootwrap.conf
auth_strategy=keystone
use_deprecated_auth=false
iscsi_helper=tgtadm
volume_api_class=nova.volume.cinder.API
local=nova.virt.libvirt.volume.LibvirtVolumeDriver,fake=nova.virt.libvirt.volume
.LibvirtFakeVolumeDriver,rbd=nova.virt.libvirt.volume.LibvirtNetVolumeDriver,she
epdog=nova.virt.libvirt.volume.LibvirtNetVolumeDriver,nfs=nova.virt.libvirt.volu
me.LibvirtNFSVolumeDriver,aoe=nova.virt.libvirt.volume.LibvirtAOEVolumeDriver,gl
usterfs=nova.virt.libvirt.volume.LibvirtGlusterfsVolumeDriver,fibre_channel=nova
.virt.libvirt.volume.LibvirtFibreChannelVolumeDriver,scality=nova.virt.libvirt.v
olume.LibvirtScalityVolumeDriver

rabbit_host=192.168.1.30
rabbit_userid=quest
rabbit_password=password
image_service=nova.image.glance.GlanceImageService
glance_api_servers=192.168.1.28:9292

network_api_class=nova.network.quantumv2.api.API
quantum_url=http://192.168.1.28:9696
quantum_auth_strategy=keystone
quantum_admin_tenant_name=service
quantum_admin_username=quantum
quantum_admin_password=password
quantum_admin_auth_url=http://192.168.1.28:35357/v2.0

service_quantum_metadata_proxy=true
quantum_metadata_proxy_shared_secret=secret

linuxnet_interface_driver=nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver=nova.virt.firewall.NoopFirewallDriver
libvirt_use_virtio_for_bridges=True

vnc_enabled=true
vncserver_proxyclient_address=192.168.1.27
novncproxy_base_url=http://192.168.1.28:6080/vnc_auto.html
vncserver_listen=0.0.0.0
vnc_keymap="en-us"

nova-compute.conf

[DEFAULT]
libvirt_type=qemu
compute_driver=libvirt.LibvirtDriver

Any help/thoughts would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

1

Hi Pavel. Can you post your nova.conf so we can take a look? Just to confirm, you are running KVM inside your ESXi cluster and not trying to use ESXI for OpenStack?

fifieldt gravatar imagefifieldt ( 2013-05-23 17:39:57 -0500 )edit

yes, I have a kvm compute node inside ESXi, not trying to use ESXi as openstack hypervisor.

vpaul gravatar imagevpaul ( 2013-05-24 04:37:52 -0500 )edit

It seems I can't attach to a comment or update the question. So, I've posted config in the answer. It is also not convenient <Enter> sends the comment.

vpaul gravatar imagevpaul ( 2013-05-24 04:42:15 -0500 )edit

thanks, I've updated your question text with that content

fifieldt gravatar imagefifieldt ( 2013-05-24 07:27:47 -0500 )edit

OK. Thanx!

vpaul gravatar imagevpaul ( 2013-05-24 09:50:37 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-07-08 01:45:59 -0500

sph gravatar image

Hi Vpaul,

I was getting a similar error on Grizzly + Debian/wheezy. After looking around the config file, I found the following comment:

By default with the Debian package, the spicehtml5 console is the default. To enable the NoVNC mode, enable the switch below, disable SPICE in this nova.conf file as well (see far below), then edit /etc/default/nova-consoleproxy to switch to NoVNC, shutdown the SPICE with /etc/init.d/nova-spicehtml5proxy stop, and finally start nova-novncproxy. Do not forget to restart Nova daemons and restart your VMs if you want to use NoVNC form now on (VMs video card needs to be attached to a console type, and they can accept only one video card at a time).

The last line was important. I had vnc_enabled set to true and the section for spice [spice] in nova.conf had the config vars on. I commented out the config in [spice] section and then my VM booted up as only vnc was on. So the gist is that you should have only one of them enabled.

edit flag offensive delete link more
0

answered 2013-05-24 10:13:32 -0500

vpaul gravatar image

It looks like spice which is configured by default was the cause.

edit flag offensive delete link more

Comments

Please accept the answer if it is working!

Jobin gravatar imageJobin ( 2013-07-08 02:29:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-22 17:52:18 -0500

Seen: 769 times

Last updated: Jul 08 '13