OVS module gives error "FATAL: openvswitch module not found"

asked 2013-09-25 09:37:56 -0500

aditya-neel09 gravatar image

Hi, I am installing quantum and openvswitch on my server. If i run the command "ovs-vsctl --version" I get the below mentioned output.

ovs-vsctl (Open vSwitch) 1.4.0+build0 Compiled Feb 18 2013 13:13:22

But when I want to check the status of my OVS, I run "ovs-vsctl show" and get the following error: Sep 25 11:35:31|00001|stream_unix|ERR|/tmp/stream-unix.51717.0: connection to /var/run/openvswitch/db.sock failed: No such file or directory Sep 25 11:35:31|00002|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)

I reload the service using "service openvswitch-switch force-reload-kmod" but again get the error that openvswitch module not found: FATAL: Module openvswitch not found. * Inserting openvswitch module * not removing bridge module because bridges exist (qbr2f96c5e6-58 qbr47f4dd43-92 qbra6cc5819-e1 qbrb032166b-da) Module has probably not been built for this kernel. Install the openvswitch-datapath-source package, then read /usr/share/doc/openvswitch-datapath-source/README.Debian Sep 25 11:20:20|00001|stream_unix|ERR|/tmp/stream-unix.48968.0: connection to /var/run/openvswitch/db.sock failed: No such file or directory Sep 25 11:20:20|00002|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory) Sep 25 11:20:21|00003|stream_unix|ERR|/tmp/stream-unix.48968.1: connection to /var/run/openvswitch/db.sock failed: No such file or directory Sep 25 11:20:21|00004|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory) Sep 25 11:20:23|00005|stream_unix|ERR|/tmp/stream-unix.48968.2: connection to /var/run/openvswitch/db.sock failed: No such file or directory Sep 25 11:20:23|00006|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory) Alarm clock * Detected internal interfaces: * ovs-brcompatd is not running * ovs-vswitchd is not running * ovsdb-server is not running * Saving interface configuration Sep 25 11:20:25|00001|dpif_linux|ERR|Generic Netlink family 'ovs_datapath' does not exist. The Open vSwitch kernel module is probably not loaded. Sep 25 11:20:25|00002|dpif|WARN|failed to enumerate system datapaths: No such file or directory FATAL: Module openvswitch not found. * Inserting openvswitch module * not removing bridge module because bridges exist (qbr2f96c5e6-58 qbr47f4dd43-92 qbra6cc5819-e1 qbrb032166b-da) * Restoring interface configuration * Enabling gre with iptables

Can anyone help me or guide me what I am doing wrong here? Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-10-03 10:41:49 -0500

aji-zqfan gravatar image

can you check if openvswitch-datapath-source and openvswitch-brcompat are installed?

edit flag offensive delete link more
0

answered 2013-10-10 13:59:51 -0500

aditya-neel09 gravatar image

Thanks ZhiQiang Fan, that solved my question.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-25 09:37:56 -0500

Seen: 1,292 times

Last updated: Oct 10 '13