nova-manage project zipfile failling

asked 2010-12-30 05:43:35 -0600

dirakx gravatar image

While testing nova-manage project zipfile proyect admin i got

Using configuration from ./openssl.cnf error loading the config file './openssl.cnf' 28641:error:02001002:system library:fopen:No such file or directory:bss_file.c:126:fopen('./openssl.cnf','rb') 28641:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:129: 28641:error:0E078072:configuration file routines:DEF_LOAD:no such file:conf_def.c:197: Traceback (most recent call last): File "./nova-manage", line 508, in <module> main() File "./nova-manage", line 500, in main fn(*argv) File "./nova-manage", line 362, in zipfile zip_file = self.manager.get_credentials(user_id, project_id) File "/home/infometrika/nova/nova/auth/manager.py", line 635, in get_credentials private_key, signed_cert = self._generate_x509_cert(user.id, pid) File "/home/infometrika/nova/nova/auth/manager.py", line 697, in _generate_x509_cert signed_cert = crypto.sign_csr(csr, pid) File "/home/infometrika/nova/nova/crypto.py", line 129, in sign_csr return _sign_csr(csr_text, FLAGS.ca_path) File "/home/infometrika/nova/nova/crypto.py", line 152, in _sign_csr (tmpfolder, tmpfolder)) File "/home/infometrika/nova/nova/utils.py", line 132, in runthis cmd=cmd) nova.exception.ProcessExecutionError: Unexpected error while running command. Command: openssl ca -batch -out /tmp/tmphMeLeD/outbound.crt -config ./openssl.cnf -infiles /tmp/tmphMeLeD/inbound.csr Exit code: 1 Stdout: None Stderr: None

but running openssl ca -batch -out /tmp/tmphMeLeD/outbound.crt -config ./openssl.cnf -infiles /tmp/tmphMeLeD/inbound.csr is succesfull, the problem there is that i don't have the .zip file and this is needed in order to have VMs working.

advice appriciated.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2011-01-05 22:08:52 -0600

dirakx gravatar image

On trouble shouting guide it says that i have to reboot in order to nova find the .cnf file, is there a way to workaround this..bacause i'm working in a production server, that i cannot reboot now.

edit flag offensive delete link more
0

answered 2011-01-06 16:42:09 -0600

dirakx gravatar image

This was due possible to a missplaced file, because i ran nova-manage form different paths.

working now.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2010-12-30 05:43:35 -0600

Seen: 29 times

Last updated: Jan 06 '11