CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'

asked 2013-05-12 20:52:57 -0600

6-jake gravatar image

I'm not sure which location (launchpad vs http://ask.openstack.org ) is better to ask questions like this, so I figured I'd post my question here too. If questions like this are meant to stay on http://ask.openstack.org , just let me know. :)

Since http://ask.openstack.org allows better syntax highlighting and my question is already there, I'm going to link to it:

https://ask.openstack.org/question/1043/critical-quantum-nonetype-object-has-no-attribute-rpartition/ (https://ask.openstack.org/question/10...)

Thanks in advance!

edit retag flag offensive close merge delete

9 answers

Sort by ยป oldest newest most voted
0

answered 2013-05-12 21:22:34 -0600

6-jake gravatar image

Thank you very much -- what should I do about this bug (where's the correct place to report it)?

edit flag offensive delete link more
0

answered 2013-05-12 21:15:37 -0600

6-jake gravatar image

So, running this directly works:

/usr/bin/quantum-l3-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/l3-agent.log'

But running this seems to want to start the lbaas: service quantum-l3-agent start

After investigating more, I see that /usr/lib/systemd/system/quantum-l3-agent.service contains: [Service] Type=simple User=quantum ExecStart=/usr/bin/quantum-lbaas-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/lbaas-agent.log PrivateTmp=false

Is this a bug? I pulled straight from the fedora repo for installing this.

edit flag offensive delete link more
0

answered 2013-05-12 21:20:01 -0600

Yes, defenitely a bug.

edit flag offensive delete link more
0

answered 2013-05-13 04:46:03 -0600

I think you may file it against quantum project

edit flag offensive delete link more
0

answered 2013-05-12 21:26:00 -0600

6-jake gravatar image

Thanks Eugene Nikanorov, that solved my question.

edit flag offensive delete link more
0

answered 2013-05-12 21:27:11 -0600

6-jake gravatar image

For anyone that comes across this later, I updated https://ask.openstack.org/question/1043/critical-quantum-nonetype-object-has-no-attribute-rpartition/?answer=1049#post-id-1049 (https://ask.openstack.org/question/10...) with more details.

edit flag offensive delete link more
0

answered 2013-05-12 21:02:02 -0600

From the console output it's not quite clear which agent are you trying to run, l3 or lbaas?

edit flag offensive delete link more
0

answered 2013-05-12 21:07:31 -0600

6-jake gravatar image

I'm trying to run the L3 agent which appears to try to run lbaas too.

edit flag offensive delete link more
0

answered 2013-05-12 21:07:52 -0600

I see now:

For some reason quantum-l3-agent refers to /usr/bin/quantum-lbaas-agent which is lbaas agent, not l3. Still it's being run with l3_agent.ini conf file which is a possible reason of failure.

You should probably be running /usr/bin/quantum-l3-agent providing path for l3_agent.ini and correspoding log file

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-12 20:52:57 -0600

Seen: 120 times

Last updated: May 13 '13