linuxbridge agent startup failure due to duplicate interface reference

asked 2013-03-07 02:01:21 -0500

ehankins gravatar image

Posted this as a followup to Bug 1067669 but it's closed so not sure if it'll be seen by anyone...

I'm not sure if this bug has affected me, but the fix seems to be affecting me, and I'm now confused about my understanding of the network_vlan_ranges and physical_interface_mappings configs.

My scenario is strictly provider network with a bunch of 802.1q VLANs riding a single bond, managed via quantum-plugin-linuxbridge...for example, my working config prior to the patch for this bug was:


physical_interface_mappings = DEV_WDMZ:bond0,DEV_APP:bond0,DEV_DB:bond0,DEV_ADMIN:bond0,DEV_STOR:bond0,DEV_WDMZSTOR:bond0,DEV_ADMZSTOR:bond0,DEV_FWEBDMZ:bond0,DEV_FWEBDMZSTOR:bond0,DEV_FDMZSTOR:bond0,DEV_ADMZ:bond0,DEV_FDMZ:bond0

After this patch, the agent fails on startup citing what would seem to be my duplicate usage of bond0:

2013-03-06 17:46:33 ERROR [quantum.plugins.linuxbridge.agent.linuxbridge_quantum_agent] Parsing physical_interface_mappings failed: Value bond0 in mapping: 'DEV_APP:bond0' not unique. Agent terminated!

It seems that a duplication of the interface value should be a nonissue -- sort of the whole point of trunking a set of VLANs across a common link via 802.1q ya?

This worked fine prior to the Bug 1067669 patch, so if someone can explain how my linuxbridge config should look for multiple network attachment to the same physical interface I'd appreciate it.


edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted

answered 2013-03-07 19:11:34 -0500

ehankins gravatar image

Thanks Robert Kukura, that solved my question.

edit flag offensive delete link more

answered 2013-03-07 13:10:00 -0500

gongysh gravatar image

How about trying: network_vlan_ranges = bond0net:1000:2999 -> replace 1000:2999 to the allowed vlan ids physical_interface_mappings = bond0net:bond0

edit flag offensive delete link more

answered 2013-03-07 19:12:48 -0500

ehankins gravatar image

Crossposting closure comment here as well:

Thanks for the information Bob, much appreciated.

I had it in my head that the network name i was specifying in my quantum net-create command needed to map all the way down to the physical_interface_mappings keys.

Now that I think about it, the --provider:physical_network <phys-net-name> is the key of reference, so my quantum net-create should look like:

quantum net-create DEV_WDMZ --provider:network_type vlan --provider:physical_network DEV_TRUNK --provider:segmentation_id 1008

Thanks again for setting me straight!

edit flag offensive delete link more

answered 2013-03-07 17:05:29 -0500

rkukura gravatar image

Yong's comment addresses specifying a pool of VLAN tags for tenant networks. Note that you do not need to specify the ranges of VLAN tags if you are only creating provider networks.

I had just posted the following explanation as a comment on the referenced bug:


It sounds like your DEV_WDMZ ... DEV_FDMZ are all VLANs on the same physical network.

If so, you should just set something like "network_vlan_ranges = DEV_TRUNK" on the quantum server, and "physical_interface_mappings = DEV_TRUNK:bond0" on the compute and network nodes.

The linuxbridge server and agent configuration only need to know about the physical network(s), not the individual provider VLANs you are allocating on the physical network.

If you are using multiple physical networks (multiple distinct VLAN trunks), then each physical network needs to be listed, as in "network_vlan_ranges = TRUNK1,TRUNK2" and "physical_interface_mappings = TRUNK1:bond0,TRUNK2:bond1". In this case VLAN X on TRUNK1 is a different isolated L2 network than VLAN X on TRUNK2.


edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-03-07 02:01:21 -0500

Seen: 265 times

Last updated: Mar 07 '13