Ask Your Question
0

tenant add throws warning from essex-3 tag on github

asked 2012-02-28 12:17:43 -0500

koolhead17 gravatar image

bin/keystone-manage tenant add admin WARNING:root:Database (mysql://keystone:keystone@192.168.1.1/keystone) is not version controlled; run keystone-manage sync_database or override your migrate version manually (see docs)

What am i doing wrong? Which particular documentation i should check to override this warning.

Also am getting the same warning at time i am starting the keystone service

/var/keystone/bin$ ./keystone

root : WARNING Database (mysql://keystone:keystone@192.168.1.1/keystone) is not version controlled; run keystone-manage sync_database or override your migrate version manually (see docs)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-03-06 18:31:40 -0500

koolhead17 gravatar image

Hi heckj, I should have closed this question after having chat at IRC. I have essex-4 keystone working with me. :)

Thanks again!!

:)

edit flag offensive delete link more
0

answered 2012-03-06 17:27:36 -0500

heckj gravatar image

koolhead17 -

This command is relevant to the Essex-3 release, but is no longer relevant to Essex4 (and the final Essex release). The updated commands are:

keystone-manage db_sync

to initialize (and migrate) your database scheme based on the config file in /etc/keystone/keystone.conf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-02-28 12:17:43 -0500

Seen: 18 times

Last updated: Mar 06 '12