Ask Your Question
0

Failed to run quantum

asked 2012-04-27 03:32:05 -0500

zhhuabj gravatar image

hi,

  I want to play with quantum, but failed.  I use quantum briage plugin. bellow are some infos:

  root@ubuntuserver:/etc/quantum# nova-manage service list

2012-04-27 11:06:25 DEBUG nova.utils [req-6fa7760e-5881-4f00-bc64-cc97ae0eb7bb None None] backend <module 'nova.db.sqlalchemy.api'="" from="" '="" bak="" openstack="" nova="" nova="" db="" sqlalchemy="" api.pyc'=""> from (pid=3981) __get_backend /bak/openstack/nova/nova/utils.py:659 Binary Host Zone Status State Updated_At nova-compute ubuntuserver nova enabled :-) 2012-04-27 03:06:26 nova-cert ubuntuserver nova enabled :-) 2012-04-27 03:06:25 nova-volume ubuntuserver nova enabled XXX 2012-04-18 10:07:24 nova-scheduler ubuntuserver nova enabled :-) 2012-04-27 03:06:24 nova-network ubuntuserver nova enabled :-) 2012-04-27 03:06:23 nova-consoleauth ubuntuserver nova enabled XXX 2012-04-18 10:07:28

root@ubuntuserver:/etc/quantum# ps -ef|grep quantum root 2319 2080 0 10:57 pts/0 00:00:01 /usr/bin/python2.7 -u /usr/lib/eclipse/dropins/org.python.pydev.debug_2.5.0.2012040618/pysrc/pydevd.py --vm_type python --client 127.0.0.1 --port 50433 --file /bak/openstack/quantum/bin/quantum-server /etc/quantum/quantum.conf -v -d root 2334 2080 0 10:57 pts/0 00:00:04 /usr/bin/python2.7 -u /usr/lib/eclipse/dropins/org.python.pydev.debug_2.5.0.2012040618/pysrc/pydevd.py --vm_type python --client 127.0.0.1 --port 55873 --file /bak/openstack/quantum/bin/quantum-linuxbridge-agent /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini -v

root@ubuntuserver:/etc/quantum# quantum list_nets default Virtual Networks for Tenant default Network ID: c65ba222-8686-4ff2-a655-b1782c996ca7 root@ubuntuserver:/etc/quantum# glance -f index ID Name Disk Format Container Format Size


f968ff93-e013-4a6b-b7c4-e9cd02c0d379 tty-ramdisk ari ari 5882349 68582208-4583-4a50-bf48-2fd007300835 tty ami ami 25165824 994b4b94-1876-45aa-9d06-8ed1ba995f93 tty-kernel aki aki 4404752 37ffd6d7-1c8e-4ef1-87d7-42e4bb068902 cirros-0.3.0-x86_64-uec ami ami 25165824 18eea6ef-edd4-4ef5-af63-1c6bacc37da2 cirros-0.3.0-x86_64-uec-ramdis ari ari 2254249 6800aef7-9e44-47a1-9612-b92f7e7d7537 cirros-0.3.0-x86_64-uec-kernel aki aki 4731440

root@ubuntuserver:/etc/quantum# nova --debug boot --image 68582208-4583-4a50-bf48-2fd007300835 --flavor 1 --nic net-id=c65ba222-8686-4ff2-a655-b1782c996ca7 test1 connect: (192.168.100.171, 35357) send: 'POST /v2.0/tokens HTTP/1.1\r\nHost: 192.168.100.171:35357\r\nContent-Length: 103\r\ncontent-type: application/json\r\naccept-encoding: gzip, deflate\r\naccept: application/json\r\nuser-agent: python-novaclient\r\n\r\n{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "admin", "password": "password"}}}' reply: 'HTTP/1.1 200 OK\r\n' header: Content-Type: application/json header: Vary: X-Auth-Token header: Content-Length: 2283 header: Date: Fri, 27 Apr 2012 03:03:15 GMT connect: (192.168.100.171, 8774) send: u'GET /v2/c84a73d4a6994abcb3c2b72bde3879bd/flavors/1 HTTP/1.1\r\nHost: 192.168.100.171:8774\r\nx-auth-project-id: admin\r\nx-auth-token: 6b9dfce202794312bec96bb779e0b8b7\r\naccept-encoding: gzip, deflate\r\naccept: application/json\r\nuser-agent: python-novaclient\r\n\r\n' reply: 'HTTP/1.1 200 OK\r\n' header: X-Compute-Request-Id: req-62d21e1d-b28d-4dd5-85d7-5f6de3a03042 header: Content-Type: application/json header: Content-Length: 357 header: Date: Fri, 27 Apr 2012 03:03:15 GMT send: u'GET /v2/c84a73d4a6994abcb3c2b72bde3879bd/images/68582208-4583-4a50-bf48-2fd007300835 HTTP/1.1\r\nHost: 192.168.100.171:8774\r\nx-auth-project-id: admin\r\nx-auth-token: 6b9dfce202794312bec96bb779e0b8b7\r\naccept-encoding: gzip, deflate\r\naccept: application/json\r\nuser-agent: python-novaclient\r\n\r\n' reply: 'HTTP/1 ...

(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-04-27 09:16:46 -0500

zhhuabj gravatar image

thank all, now I have solved this problem. the reason is memory of my virtual machine is too low, thus it can't meet the demand of scheduler/filters/ram_filter.py so I append following line in /etc/nova/nova.conf ram_allocation_ratio=3

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-27 03:32:05 -0500

Seen: 16 times

Last updated: Apr 27 '12