Ask Your Question
0

Ubuntu & Folsom -- Stuck with Nova -- "Please input your password for the keyring"

asked 2012-10-06 09:02:11 -0500

tungns-inf gravatar image

I'm trying to install Openstack Folsom in Ubuntu 12.04 following trunk documents: http://docs.openstack.org/trunk/openstack-compute/install/apt/content/compute-minimum-configuration-settings.html (http://docs.openstack.org/trunk/opens...)

It's fine with keystone and glance. I checked and both of them work great. After install all nova package and configuring, I run nova-manage db sync with no problem. But when I check:

$ nova-manage services list

it returned nothing.

I check with other command like:

$ nova image-list

then it ask for enter a password

"Please input your password for the keyring" "Wrong password for the keyring."

There is nothing in the /var/log/nova/

I've never ever in this situation. Here is my nova.conf

[DEFAULT]

LOGS/STATE

--verbose=True --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova

AUTHENTICATION

--auth_strategy=keystone

SCHEDULER

--compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler

VOLUMES

--volume_driver=nova.volume.driver.ISCSIDriver --volume_group=nova-volumes --volume_name_template=volume-%08x --iscsi_helper=tgtadm

DATABASE

--sql_connection=mysql://nova:nova@172.17.17.21/nova_db

COMPUTE

--libvirt_type=qemu --compute_driver=libvirt.LibvirtDriver --instance_name_template=instance-%08x --api_paste_config=/etc/nova/api-paste.ini --allow_resize_to_same_host=True

APIS

--osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions --ec2_dmz_host=172.17.17.21 --s3_host=172.17.17.21

RABBITMQ

--rabbit_host=172.17.17.21

GLANCE

--image_service=nova.image.glance.GlanceImageService --glance_api_servers=172.17.17.21:9292

NETWORK

--network_manager=nova.network.manager.VlanManager --force_dhcp_release=True --dhcpbridge_flagfile=/etc/nova/nova.conf --firewall_driver=nova.virt.libvirt.firewall.IptablesFirewallDriver

Change my_ip to match each host

--my_ip=172.17.17.21 --public_interface=eth0 --vlan_interface=eth0 --fixed_range=10.0.0.0/24

NOVNC CONSOLE

--novncproxy_base_url=http://172.17.17.21:6080/vnc_auto.html

Change vncserver_proxyclient_address and vncserver_listen to match each compute host

--vncserver_proxyclient_address=172.17.17.21 --vncserver_listen=172.17.17.21

[keystone_authtoken] --auth_host = 172.17.17.21 --auth_port = 35357 --auth_protocol = http --auth_uri = http://172.17.17.21:5000/ --admin_tenant_name =service --admin_user = nova --admin_password = nova

In this guide version, there is not require config admin_* after [filter:authtoken] in /etc/nova/api-paste.ini. I also changed these config, but it did not work.

What should I do?

Thank you!

edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
0

answered 2012-10-06 09:32:50 -0500

endre-karlson gravatar image

Add this to your .bashrc export OS_NO_CACHE=1

And try again Den 6. okt. 2012 11:06 skrev "neo0" question210500@answers.launchpad.net følgende:

New question #210500 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+question/210500 (https://answers.launchpad.net/nova/+q...)

I'm trying to install Openstack Folsom in Ubuntu 12.04 following trunk documents:

http://docs.openstack.org/trunk/openstack-compute/install/apt/content/compute-minimum-configuration-settings.html (http://docs.openstack.org/trunk/opens...)

It's fine with keystone and glance. I checked and both of them work great. After install all nova package and configuring, I run nova-manage db sync with no problem. But when I check:

$ nova-manage services list

it returned nothing.

I check with other command like:

$ nova image-list

then it ask for enter a password

"Please input your password for the keyring" "Wrong password for the keyring."

There is nothing in the /var/log/nova/

I've never ever in this situation. Here is my nova.conf

[DEFAULT]

LOGS/STATE

--verbose=True --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova

AUTHENTICATION

--auth_strategy=keystone

SCHEDULER

--compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler

VOLUMES

--volume_driver=nova.volume.driver.ISCSIDriver --volume_group=nova-volumes --volume_name_template=volume-%08x --iscsi_helper=tgtadm

DATABASE

--sql_connection=mysql://nova:nova@172.17.17.21/nova_db

COMPUTE

--libvirt_type=qemu --compute_driver=libvirt.LibvirtDriver --instance_name_template=instance-%08x --api_paste_config=/etc/nova/api-paste.ini --allow_resize_to_same_host=True

APIS

--osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions --ec2_dmz_host=172.17.17.21 --s3_host=172.17.17.21

RABBITMQ

--rabbit_host=172.17.17.21

GLANCE

--image_service=nova.image.glance.GlanceImageService --glance_api_servers=172.17.17.21:9292

NETWORK

--network_manager=nova.network.manager.VlanManager --force_dhcp_release=True --dhcpbridge_flagfile=/etc/nova/nova.conf --firewall_driver=nova.virt.libvirt.firewall.IptablesFirewallDriver

Change my_ip to match each host

--my_ip=172.17.17.21 --public_interface=eth0 --vlan_interface=eth0 --fixed_range=10.0.0.0/24

NOVNC CONSOLE

--novncproxy_base_url=http://172.17.17.21:6080/vnc_auto.html

Change vncserver_proxyclient_address and vncserver_listen to match each

compute host --vncserver_proxyclient_address=172.17.17.21 --vncserver_listen=172.17.17.21

[keystone_authtoken] --auth_host = 172.17.17.21 --auth_port = 35357 --auth_protocol = http --auth_uri = http://172.17.17.21:5000/ --admin_tenant_name =service --admin_user = nova --admin_password = nova

In this guide version, there is not require config admin_* after [filter:authtoken] in /etc/nova/api-paste.ini. I also changed these config, but it did not work.

What should I do?

Thank you!


You received this question notification because you are an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2012-10-06 16:00:10 -0500

tungns-inf gravatar image

Thanks Endre Karlson, that solved my question.

edit flag offensive delete link more
0

answered 2012-10-06 16:03:39 -0500

tungns-inf gravatar image

Thank you Endre. Following your suggest, I checked this document then understand problem: http://www.rackspace.com/knowledge_center/article/installing-python-novaclient-on-linux-and-mac-os (http://www.rackspace.com/knowledge_ce...)

but after fix it. I still can not run nova. When I run:

$ nova image-list ERROR: ConnectionRefused: '[Errno 111] Connection refused'

and there is no log file in /var/log/nova.

I tried to remove nova_db and recreate, sync database several times but didn't work.

What should I do next?

edit flag offensive delete link more
0

answered 2012-10-06 16:45:46 -0500

tungns-inf gravatar image

Sorry. I solved it. Because I am using the old type flags with -- before each line in nova.conf. When I change to use INI type. It work! :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-10-06 09:02:11 -0500

Seen: 88 times

Last updated: Oct 06 '12