nova boot silently picks up IP Address for External Network

asked 2012-11-16 22:11:53 -0600

sunil-srivastava gravatar image

I ran devstack stack.sh, and it created private and external network.

I could do ssh using private, access Internet from inside VM, and also do Floating IP. nova boot did not have any options for --nic. VMs had not picked up any addresses on External Net.

Then I manually removed the port, network, subnet, gateway and router, besides deleting detaching and deleting floating ip assigned.

Afterwards, I manually did the same steps which devstack stack.sh does and did nova boot without --nic option.

The two VMs I had spawned had also picked up external IP Addresses.

192.168.128/28 was used as external network. 129 went to br-ex, 130 went to gg*, and 131 and 132 got assigned to 2 VMs. I could still do FLoating IP with 133 and 134. Besides ssh from Management Controller Node on Floating IPs, I could only SSH 131 which went to remote node but not to local 132. Routes point to br-ex. There were no DNAT/SNAT rules for 132 and 131.

Following CLIs were run.

quantum net-create ext_net -- --router:external=True quantum subnet-create --ip_version 4 66bb2246-51db-4b09-a608-e91f83b64bbb $FLOATING_RANGE -- --enable_dhcp=False

This sounds like some bug.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-24 07:53:47 -0600

caiqishen gravatar image

i got the sam problem as yours! I have no idea how to slove it

edit flag offensive delete link more
0

answered 2012-11-17 05:38:40 -0600

gongysh gravatar image

I think in devstack, we are using different tenants for external network and private tenant. by your manual steps, you may create the networks by one tenant.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-16 22:11:53 -0600

Seen: 71 times

Last updated: Nov 24 '12