Keystone won't start on running system

asked 2012-10-19 17:43:04 -0600

johndesp gravatar image

I am running Folsom Ubuntu 12.04. My system was fine. I received a call from a power user that told me he could not log in. I traced the problem back to the fact the keystone was not up. I don't see anything listening on port 35357.

I tried to start keystone.

The service reported back that keystone started with a pid number.

However, there is no pid and nothing listening on port 35357.

Can anyone point me in a direction to discover root cause? The keystone log is not moving.



edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2012-10-20 21:19:46 -0600

heckj gravatar image

Hi John,

I'm not familiar with the upstart or init script that's provided by Ubuntu's distribution, but I'd recommend running what is inside that script explicitly from the relevant user (I think Ubuntu creates a "keystone" user in it's distribution) and see if there's an error message appearing on the console that isn't making it to the logs.

I would expect any normal error to appear in /var/log/keystone/keystone.log immediately after you invoked the service start.

edit flag offensive delete link more

answered 2012-12-04 10:37:28 -0600

rajeshkannan007 gravatar image

Hi John,

Check the auth_port value in all conf files, including cinder.conf, cinder-api.ini, glance-api.conf, glance-registry.conf, glance-api-paste.ini, glance-registry-paste.ini, nova/api-paste.ini...

Make sure that the value of the auth_port should be equal to 35357. It its not then change it and restart all services associate to it..

Let me know its working or not..

Regards, Rajesh kannan

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2012-10-19 17:43:04 -0600

Seen: 264 times

Last updated: Dec 04 '12