Ask Your Question
0

Unable to communicate with identity service: [Errno 111] Connection refused. (HTTP 400)

asked 2012-11-27 10:21:17 -0500

sudhakar-gariganti gravatar image

I am trying to setup this up: http://docs.openstack.org/folsom/basic-install/content/basic-install_controller.html (http://docs.openstack.org/folsom/basi...)

I am stuck at the Keystone step.Getting this error when I run the data script @Step5 of Keystone:

"No handlers could be found for logger "keystoneclient.client" Unable to communicate with identity service: [Errno 111] Connection refused. (HTTP 400)"

Seems like the keystone tables are not populated. All the tables in the database, have no data.

I have tried syncing the database again and restarted the keystone service, but I am still getting the same error.

Any idea what I need to do to get this resolved?? Please let me know if you need any specific information about my setup.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-28 16:01:15 -0500

sudhakar-gariganti gravatar image

Sorry for the trouble. I have figured out the error in the keystone.conf file. Correcting the conf file, solved my issue.

edit flag offensive delete link more
0

answered 2012-11-27 14:58:23 -0500

sudhakar-gariganti gravatar image

Thanks for replying Martin. Yes, I am running all the scripts/commands as root only. Hence did not use sudo there.

edit flag offensive delete link more
0

answered 2012-11-27 13:50:50 -0500

Did you run keystone-manage db_sync as root? Just checked that there is no error message if run it without sudo. Try running sudo keystone-manage db_sync

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-27 10:21:17 -0500

Seen: 37 times

Last updated: Nov 28 '12