Ask Your Question
1

Cannot ping Internet hosts via Quantum router

asked 2013-05-21 12:52:12 -0500

polslinux gravatar image

updated 2013-09-28 09:01:18 -0500

darragh-oreilly gravatar image

This is my environment (i'm under my {proxed} University network):
* vmware esxi 5.0 with an Ubuntu 13.04 server vm (openstack grizzly);
* 172.25.27.5 is the lan ip of that vm;
* 172.25.27.250 is the gateway ip;
* single node architecture;
I want to configurate network, subnet and router with quantum and i would like to know if this is the right way:

quantum net-create public --router:external=True
quantum subnet-create public 172.25.27.0/24 --gateway 172.25.27.250
quantum net-create net1
quantum subnet-create net1 10.0.0.0/24
quantum net-create net2
quantum subnet-create net2 10.0.1.0/24
quantum router-create router1
quantum router-interface-add router1 <subnet1-uuid>
quantum router-interface-add router1 <subnet2-uuid>
quantum router-gateway-set router1 <ext-net-id>

and then from horizon i create the floating ip.
Am i doing the right thing? Because if i boot CirrOS 0.3.0 and i try to ping google.com i got "bad host bla bla". Obviously i'm associating the floating ip with that instance.

I also got this (this can be seen from horizon under Network->Ports):

(cba23354) 172.25.27.1  network:router_gateway  DOWN    UP
(18641698) 172.25.27.2  network:floatingip      DOWN    UP
(4d76f2c9) 172.25.27.4  network:dhcp              ACTIVE  UP
edit retag flag offensive close merge delete

Comments

Actually the DOWN statuses might be a bug in Quantum - I see that too but everything is working. Even 'quantum port-list -c status -c fixed_ips' shows them DOWN so it is not Horizon. Or maybe because they are external Quantum does not manage them and does not know their status.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-05-21 15:44:19 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-05-21 13:34:48 -0500

darragh-oreilly gravatar image

updated 2013-09-28 09:07:01 -0500

Maybe it is a DNS problem - try pinging 8.8.8.8 from an instance. If that works you can set the dns_nameservers on private subnets and dhcp will push it out to the instances.

quantum subnet-update <subnet-of-net1-id> --dns_nameservers 8.8.4.4 8.8.8.8 </subnet-of-net1-id>

Update: after re-reading this it seems you have an all-in-one on an ESX-VM with a NIC with 172.25.27.5 and you want to use this same NIC for your floating IPs. The doc says that the NIC used for external access (connected to br-ex) should not have an IP.

http://docs.openstack.org/trunk/openstack-network/admin/content/install_quantum-l3.html

Update: The floating IPs and router_gateway showing status DOWN has been fixed here.

edit flag offensive delete link more

Comments

there's something wrong with my configuration because i've clicked on "add floating ip" from horizon and a floating ip (172.25.27.5) was added BUT this address is already in use by my vm O.o how can this be possible???

polslinux gravatar imagepolslinux ( 2013-05-21 14:19:01 -0500 )edit
1

When you created the external subnet for floating IPs you should have used --enable_dhcp False. Now you have 172.25.27.4 network:dhcp on it - I'm not sure if that causes a problem though.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-05-21 15:47:18 -0500 )edit

when you are creating floating ip pool you are taking entire subnet 172.25.27.0/24 . Rather you should use the pool of IP's which are free and not used by other systems in that network. Only that makes sense to me.

Ashokb gravatar imageAshokb ( 2013-05-24 02:34:07 -0500 )edit

Also if you are using single NIC you can have different vlans for simulating management/vm network and external lan.For an instance eth0 can be part of management vlan, and eth0.10 can be part of external network(vlantag 10),while configuring br-ex you can add the port as eth0.10. one possible way

Ashokb gravatar imageAshokb ( 2013-05-24 02:41:57 -0500 )edit

I suggested the above way to overcome the br-ex ip assignment issue stated by darregh.

Ashokb gravatar imageAshokb ( 2013-05-24 02:43:09 -0500 )edit
1

answered 2013-09-27 19:30:52 -0500

pabelanger gravatar image

updated 2013-09-27 19:31:39 -0500

So, I think your issue is you are launching your VMs with _both_ networks (net1 / net2 and public). For me, I had to only select net1 or net2 when launching my VM. Then, you assign a floating IP from your public network.

From within your VM, you should only have 1 ethernet interface and openstack NATs the traffic on the public network.

Plus like what others said, you didn't pass a DNS server to your net1 / net2 network.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-21 12:52:12 -0500

Seen: 2,587 times

Last updated: Sep 28 '13