Ask Your Question
0

configuring and running swift-tempurl

asked 2012-05-22 19:16:57 -0600

saeid-whb gravatar image

Hi, I installed swift-tempurl and my proxy-server.conf is very simple as follow:

[DEFAULT] bind_port = 8080 user = swift log_facility = LOG_LOCAL1

[pipeline:main] pipeline = catch_errors cache tempurl swauth tempauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true account_autocreate = true

[filter:tempurl] use = egg:swifttempurl#tempurl

[filter:tempauth] use = egg:swift#tempauth user_test_tester = testing .admin allow_overrides = true

[filter:swauth] use = egg:swauth#swauth set log_name = swauth super_admin_key = swauthkey default_swift_cluster =local#http://10.10.10.238:8080/v1 allow_overrides = true

[filter:catch_errors] use = egg:swift#catch_errors

[filter:cache] use = egg:swift#memcache

I reloaded the proxy server but when I use curl with the tempurl I get the following error:

401 Unauthorized: Temp URL invalid

Any Suggestion? anything wrong with configuration file? Thanks

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-05-31 14:59:32 -0600

saeid-whb gravatar image

Thank you that solved my problem.

edit flag offensive delete link more
0

answered 2012-05-31 05:45:38 -0600

you have two auth middle-wares in swift, I don't know whether swift can work normally. Maybe you can remove 'swauth' from pipeline ,then try it again.

edit flag offensive delete link more
0

answered 2012-05-31 05:45:35 -0600

you have two auth middle-wares in swift, I don't know whether swift can work normally. Maybe you can remove 'swauth' from pipeline ,then try it again.

edit flag offensive delete link more
0

answered 2012-07-09 07:49:47 -0600

hettbox gravatar image

Why with it config, i have error:

root@proxy:/etc/swift# swift-init proxy restart Signal proxy-server pid: 1643 signal: 15 proxy-server (1643) appears to have stopped Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/usr/lib/python2.7/dist-packages/swift/common/wsgi.py", line 122, in run_wsgi loadapp('config:%s' % conf_file, global_conf={'log_name': log_name}) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 247, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 271, in loadobj global_conf=global_conf) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext global_conf=global_conf) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 450, in get_context global_additions=global_additions) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 559, in _pipeline_app_context APP, pipeline[-1], global_conf) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 408, in get_context object_type, name=name) File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 587, in find_config_section self.filename)) LookupError: No section 'tempurl' (prefixed by 'app' or 'application' or 'composite' or 'composit' or 'pipeline' or 'filter-app') found in config /etc/swift/proxy-server.conf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-05-22 19:16:57 -0600

Seen: 107 times

Last updated: Jul 09 '12