Ask Your Question
0

VM ssh fails - FlatDHCP

asked 2012-04-23 12:34:33 -0500

roshanbaliga gravatar image

Hi, I am trying to bring up a private cloud on 2 machines using the latest Openstack Essex release on Ubuntu 12.04. Each of the machines has 2 NICs.

On one of the machines, I start the keystone, glance , nova (libvirt-bin nova-network nova-compute nova-api nova-objectstore nova-scheduler nova-volume nova-vncproxy) & dashboard services. On this machine I am able to create a VM instance (Name: vm1) & ssh to the instance. My nova.conf file on this machine looks like this:

--dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --allow_admin_api=true --use_deprecated_auth=false --auth_strategy=keystone --scheduler_driver=nova.scheduler.simple.SimpleScheduler --s3_host=192.168.1.201 --ec2_host=192.168.1.201 --rabbit_host=192.168.1.201 --cc_host=192.168.1.201 --nova_url=http://192.168.1.201:8774/v1.1/ --routing_source_ip=192.168.1.201 --glance_api_servers=192.168.1.201:9292 --image_service=nova.image.glance.GlanceImageService --iscsi_ip_prefix=10.0.1 --sql_connection=mysql://novadbadmin:nova@192.168.1.201/nova --ec2_url=http://192.168.1.201:8773/services/Cloud --keystone_ec2_url=http://192.168.1.201:5000/v2.0/ec2tokens --api_paste_config=/etc/nova/api-paste.ini --libvirt_type=kvm --libvirt_use_virtio_for_bridges=true --start_guests_on_host_boot=true --resume_guests_state_on_host_boot=true --vnc_enabled=true --vncproxy_url=http://192.168.1.201:6080 --vnc_console_proxy_url=http://192.168.1.201:6080

network specific settings

--network_manager=nova.network.manager.FlatDHCPManager --public_interface=eth0 --flat_interface=eth1 --flat_network_bridge=br100 --fixed_range=10.0.1.0/24 --floating_range=192.168.1.240/29 --network_size=8 --flat_network_dhcp_start=10.0.1.2 --flat_injected=False --force_dhcp_release --iscsi_helper=tgtadm --connection_type=libvirt --root_helper=sudo nova-rootwrap

--verbose

I then bring up the 2nd machine with eth0 static IP address set to 192.168.1.202 & start nova (libvirt-bin nova-compute) services. My nova.conf file on this machine is the same as above with just one additional entry for network_host

--network_host=192.168.1.201

I am able to create a VM on this machine using dashboard (Name: vm2) and the VM comes up. I have also verified this by running nova show vm2 (The OS-EXT-SRV-ATTR:host attribute is pointing to the right hostname). But I am unable to SSH to this instance (SSH error: Read from socket failed: Connection reset by peer) I am suspecting a firewall issue. Do I need to explicitly configure iptables on the 2nd machine?

-Roshan

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-04-24 06:03:35 -0500

roshanbaliga gravatar image

I am attaching the nova-compute.log here. It appears that the machine with nova-compute only is getting a message to reboot a VM instance that does not exist. Any help in debugging will be greatly appreciated +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

2012-04-24 11:15:09 DEBUG nova.service [-] Full set of FLAGS: from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:402 2012-04-24 11:15:09 DEBUG nova.service [-] default_floating_pool : nova from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] storage_availability_zone : nova from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] rescue_image_id : None from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] num_networks : 1 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] default_publisher_id : luke from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] sql_connection_debug : 0 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] fixed_range : 10.0.1.0/24 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] compute_topic : compute from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] glance_port : 9292 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] glance_api_servers : ['192.168.1.201:9292'] from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] rabbit_password : FLAG SET from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:409 2012-04-24 11:15:09 DEBUG nova.service [-] osapi_compute_listen_port : 8774 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] s3_dmz : 192.168.1.202 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] quota_ram : 51200 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] xenapi_sparse_copy : True from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] osapi_compute_listen : 0.0.0.0 from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] cache_images : True from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] vlan_interface : None from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-04-24 11:15:09 DEBUG nova.service [-] aws_access_key_id : FLAG SET from (pid=4599) wait /usr/lib/python2.7/dist-packages/nova/service.py:409 2012-04-24 11:15:09 DEBUG nova ... (more)

edit flag offensive delete link more
0

answered 2012-04-24 09:47:33 -0500

roshanbaliga gravatar image

Deleted nova database in Mysql. Create fresh database & reinstalled nova components on machine 1

edit flag offensive delete link more
0

answered 2012-08-10 19:22:39 -0500

entropyworks gravatar image

Did deleting the db and reinstall the nova components fix the problem?

edit flag offensive delete link more
0

answered 2012-08-11 06:13:46 -0500

roshanbaliga gravatar image

Yes. This seemed to fix the issue for me.

On Sat, Aug 11, 2012 at 12:55 AM, Yazz D. Atlas < question194472@answers.launchpad.net > wrote:

Your question #194472 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/194472 (https://answers.launchpad.net/nova/+q...)

Yazz D. Atlas posted a new comment: Did deleting the db and reinstall the nova components fix the problem?


You received this question notification because you asked the question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-23 12:34:33 -0500

Seen: 76 times

Last updated: Aug 11 '12