Ask Your Question
0

Have you met similar issue with tools/install_venv.py script?

asked 2012-03-21 08:18:23 -0500

Vincent gravatar image

Firstly, please allow me to give my acknowledgement to nova developers for providing install_venv.py script to set up the development environment for nova. It really gives me a lot of help to better understand nova's dependencies. However, I am not sure whether it is due to the problem of my local network connection. Each time I run python tools/install_venv.py, I always get a failure because one package(it could be anyone) within pip-requires failed to download or install. No matter how many times I tried, there is no single success for me. Then, I tried to split all the packages within pip-requires by converting them into a set of commands one by one. For example, there is amqplib==0.6.1, then I will get a command sudo tools/with_venv.sh pip install amqplib==0.6.1... When I run these commands one by one, the packages can be successfully installed. After it, I run install_venv.py, then I will have virtualenv successfully installed. I was wondering if anyone of you has got similar issues. Is it due to the local network connection? Do you think it is an issue for us to fix it in the script code?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-03-23 06:58:10 -0500

koolhead17 gravatar image

Might be because of network connection issue. See if you have a reliable name server listed inside your /etc/resolv.conf

Hope it helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-03-21 08:18:23 -0500

Seen: 104 times

Last updated: Mar 23 '12