Ask Your Question
0

swift proxy server - connection reset error by peer

asked 2011-12-03 02:07:10 -0500

tpatil gravatar image

I have installed swift 1.4.5 on a single server and have configured proxy server with the following settings:-

root@ubuntu-test-machine:/etc/rsyslog.d# dpkg -s swift Package: swift Status: install ok installed Priority: optional Section: net Installed-Size: 308 Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com Architecture: all Version: 1.4.5~20111202.1634-0ubuntu0ppa1~maverick1

I have followed steps mentioned here http://docs.openstack.org/diablo/openstack-object-storage/admin/content/installing-and-configuring-the-proxy-node.html (http://docs.openstack.org/diablo/open...) to install proxy server on a single node.

proxy-server.conf

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_ip=10.2.3.86 bind_port = 8080 workers = 1 user = swift group = swift

log_facility = LOG_LOCAL0 log_level = DEBUG log_name = swift-p log_requests = true setup_console_handler = true

[pipeline:main] pipeline = healthcheck cache tempauth proxy-server

[app:proxy-server] use = egg:swift#proxy account_autocreate = true set log_name = proxy-server set log_facility = LOG_LOCAL0 set log_level = DEBUG set access_log_name = proxy-server set access_log_facility = LOG_LOCAL0 set access_log_level = DEBUG set log_requests = true

[filter:tempauth] use = egg:swift#tempauth user_admin_admin = admin .admin .reseller_admin user_test_tester = testing .admin user_test2_tester2 = testing2 .admin user_test_tester3 = testing3

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = 10.2.3.86:11211

Now if I try to send curl command to get the x-auth-token, it look likes the request is sent but the proxy server doesn't send any response. After few minutes it gives an error message "Connection reset by Peer"

root@ubuntu-test-machine:/etc/swift# curl -k -v -H 'x-auth-user: test:tester' -H 'x-auth-key: testing' http://10.2.3.86:8080/auth/v1.0 * About to connect() to 10.2.3.86 port 8080 (#0) * Trying 10.2.3.86... connected * Connected to 10.2.3.86 (10.2.3.86) port 8080 (#0)

GET /auth/v1.0 HTTP/1.1 User-Agent: curl/7.21.0 (x86_64-pc-linux-gnu) libcurl/7.21.0 OpenSSL/0.9.8o zlib/1.2.3.4 libidn/1.18 Host: 10.2.3.86:8080 Accept: / x-auth-user: test:tester x-auth-key: testing

There are no logs in the /var/log/messages. so I don't have any clue what is happening.

Any assistance will be greatly appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2011-12-06 16:07:53 -0500

btorch gravatar image

You need to use HTTPS since you are specifying the cert/key parameters into your proxy.conf file. You also need to specify the proper storage URL for the tempauth users. Check out the proxy-server sample file which should be under /usr/share/doc/swift-proxy/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-12-03 02:07:10 -0500

Seen: 369 times

Last updated: Dec 06 '11