Ask Your Question
0

SSH to VM failed

asked 2013-04-19 16:43:12 -0500

nassim-kaabache gravatar image

Hi, I create my own Cloud, I create a VM. I can ping but I can't SSH it. thx for help

test@one-PC:/usr/lib/ltp$ ping 172.16.0.3 PING 172.16.0.3 (172.16.0.3) 56(84) bytes of data. 64 bytes from 172.16.0.3: icmp_req=1 ttl=64 time=0.271 ms 64 bytes from 172.16.0.3: icmp_req=2 ttl=64 time=0.208 ms ^C --- 172.16.0.3 ping statistics --- 2 packets transmitted, 2 received, 0% packet loss, time 1000ms rtt min/avg/max/mdev = 0.208/0.239/0.271/0.035 ms test@one-PC:/usr/lib/ltp$ ssh -vvvv 172.16.0.3 OpenSSH_6.0p1 Debian-3ubuntu1, OpenSSL 1.0.1c 10 May 2012 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 172.16.0.3 [172.16.0.3] port 22. debug1: connect to address 172.16.0.3 port 22: Connection refused ssh: connect to host 172.16.0.3 port 22: Connection refused

edit retag flag offensive close merge delete

13 answers

Sort by ยป oldest newest most voted
0

answered 2014-02-21 17:03:52 -0500

nassim-kaabache gravatar image

My VM didn't have ssh server on it.

edit flag offensive delete link more
0

answered 2013-04-22 10:17:38 -0500

Did you create security group to allow ssh connect? example: nova secgroup-add-rule openpub icmp -1 -1 0.0.0.0/0 nova secgroup-add-rule openpub tcp 22 22 0.0.0.0/0

edit flag offensive delete link more
0

answered 2013-04-22 12:25:28 -0500

nassim-kaabache gravatar image

yes I add it in the dashboard and in command line, but even without icmp rules I can ping my VM. Maybe there is a problem of settings, I don't know.

edit flag offensive delete link more
0

answered 2013-04-23 11:04:03 -0500

what is the console output when you ssh to the vm?

edit flag offensive delete link more
0

answered 2013-04-24 12:25:28 -0500

nassim-kaabache gravatar image

I create the keypair, add it to the VM and try to ssh but it failed and it didn't talk about rsa key. I go to the VM and the ~/.ssh/authorized_keys is the same as mine. I try to telnet but it failed too. I try different port but nothing better.

edit flag offensive delete link more
0

answered 2013-04-29 12:58:55 -0500

nassim-kaabache gravatar image

Thank you very much it was all my fault...

edit flag offensive delete link more
0

answered 2013-04-29 12:59:22 -0500

nassim-kaabache gravatar image

There was a ssh client but no ssh server

edit flag offensive delete link more
0

answered 2014-02-21 09:05:17 -0500

liuqi-edward gravatar image

hello kaabache

I faced the same question with you. Could you tell which server don't have a ssh server?

Thanks!

edit flag offensive delete link more
0

answered 2013-04-22 08:07:11 -0500

nassim-kaabache gravatar image

Sorry I write it too quickly. I manage to create a VM with OpenStack. I add the rules for ping and ssh on OpenStack. There is a client SSH on my VM. But the ping is ok but not the SSH. I don't have any clue where is the problem, I can send you the nova.conf or all my config s network... I try with or without RSA key =/

I try this too :

killall dnsmasq

service nova-network restart

Can you help me ?

edit flag offensive delete link more
0

answered 2013-04-23 12:03:46 -0500

nassim-kaabache gravatar image

it is this one : test@one-PC:/usr/lib/ltp$ ssh -vvvv 172.16.0.3 OpenSSH_6.0p1 Debian-3ubuntu1, OpenSSL 1.0.1c 10 May 2012 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 172.16.0.3 [172.16.0.3] port 22. debug1: connect to address 172.16.0.3 port 22: Connection refused ssh: connect to host 172.16.0.3 port 22: Connection refused

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-19 16:43:12 -0500

Seen: 609 times

Last updated: Feb 24 '14