Ask Your Question
0

cinder volume creation (status : creating)

asked 2012-11-05 12:18:47 -0500

rajeshkannan007 gravatar image

Hi, I am trying openstack manual installation on a single node with the help of the manual http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ap_installingfolsomubuntuprecise.html (http://docs.openstack.org/trunk/opens...)

I got stucked in creating volumes in cinder configuration

When i execute the command $ cinder create --display_name test 1

it gives,

+---------------------+--------------------------------------+ | Property | Value | +---------------------+--------------------------------------+ | attachments | [] | | availability_zone | nova | | created_at | 2012-11-05T11:59:59.548149 | | display_description | None | | display_name | test | | id | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | | metadata | {} | | size | 1 | | snapshot_id | None | | status | creating | | volume_type | None | +---------------------+--------------------------------------+

And the status of the volume remains in creating

When i execute the command $ cinder list

it gives +--------------------------------------+----------+--------------+------+-------------+-------------+ | ID | Status | Display Name | Size | Volume Type | Attached to | +--------------------------------------+----------+--------------+------+-------------+-------------+ | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | creating | test | 1 | None | | +--------------------------------------+----------+--------------+------+-------------+-------------+

the status of the volume should be 'Available', But in my case it still remains in 'creating' state

and my cinder.conf looks like, [DEFAULT] rootwrap_config = /etc/cinder/rootwrap.conf sql_connection = mysql://cinder:openstack@.../cinder api_paste_confg = /etc/cinder/api-paste.ini

iscsi_helper = ietadm volume_name_template = volume-%s volume_group = cinder-volumes verbose = True auth_strategy = keystone state_path = /var/lib/cinder volumes_dir = /var/lib/cinder/volumes #osapi_volume_listen_port=5900

and the part of my api-paste.ini file looks like, [filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = x.y.z.a service_port = 5000 auth_host = x.y.z.a auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = cinder admin_password = openstack

Please help me fix it..

Its urgent i need..

regards Rajesh kannan

edit retag flag offensive close merge delete

29 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-21 06:16:29 -0500

rajeshkannan007 gravatar image

Thanks Razique Mahroua, that solved my question.

edit flag offensive delete link more
0

answered 2012-11-09 15:10:57 -0500

what cinder list gives you ? you are fine by using the loopfile for testing purpose, but of you intend to run production for that, you might consider other leads - SAN for instance, dedicated disk in RAID, etc...

edit flag offensive delete link more
0

answered 2012-11-09 04:55:06 -0500

rajeshkannan007 gravatar image

Thank you Razique,

Its working.. now i can delete the volume. Thanks a lot..

Now there is no volume in the volumes tab. so, i attended to create a new volume by following the steps from beginning, when i reach the $ cinder create --display_name test 1 its shows me an error..

ERROR: VolumeLimitExceeded: Maximum number of volumes allowed (10) exceeded (HTTP 413) (Request-ID: req-f560458f-4132-4a98-bf2a-c009a447b229)

But nothing is there in the volume tab as well as database. what should i do to create volume in exist partition..? Otherwise shall i create a new partition,? if so, please tell me the way which i should follow..

Thank you

edit flag offensive delete link more
0

answered 2012-11-08 12:14:16 -0500

try to run a cinder delete $id otherwhise, edit manually the database and set the "deleted" field to 1 since the volume doesn't exist

edit flag offensive delete link more
0

answered 2012-11-08 12:13:35 -0500

try to run

edit flag offensive delete link more
0

answered 2012-11-08 11:35:02 -0500

rajeshkannan007 gravatar image

Can you tell me the way to delete the available volume..

I tried it.. but now the status remains 'error_deleting'

can i delete the available volume? if so please tell me the command..

otherwise how to make it as available again..?

thanks and regards, R.Rajesh kannan

edit flag offensive delete link more
0

answered 2012-11-08 11:29:09 -0500

rajeshkannan007 gravatar image

Thanks Razique Mahroua, that solved my question.

edit flag offensive delete link more
0

answered 2012-11-08 11:28:42 -0500

rajeshkannan007 gravatar image

Thank you.. its now created.. thank you for your replies, answers... Thank you for your time..

edit flag offensive delete link more
0

answered 2012-11-08 08:42:51 -0500

Can you try to create a bigger file (let's say 3 gb) and try again both fsdisk and the mount/ pvcreate, etc... thanks

edit flag offensive delete link more
0

answered 2012-11-08 05:24:03 -0500

rajeshkannan007 gravatar image

No I'm using sudo for the mounting and lvm ones..

Because after using sudo only its executed.. otherwise its not working..

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-05 12:18:47 -0500

Seen: 731 times

Last updated: Nov 21 '12