Ask Your Question
0

cinder volume creation (status : creating)

asked 2012-11-05 12:18:47 -0500

rajeshkannan007 gravatar image

Hi, I am trying openstack manual installation on a single node with the help of the manual http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ap_installingfolsomubuntuprecise.html (http://docs.openstack.org/trunk/opens...)

I got stucked in creating volumes in cinder configuration

When i execute the command $ cinder create --display_name test 1

it gives,

+---------------------+--------------------------------------+ | Property | Value | +---------------------+--------------------------------------+ | attachments | [] | | availability_zone | nova | | created_at | 2012-11-05T11:59:59.548149 | | display_description | None | | display_name | test | | id | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | | metadata | {} | | size | 1 | | snapshot_id | None | | status | creating | | volume_type | None | +---------------------+--------------------------------------+

And the status of the volume remains in creating

When i execute the command $ cinder list

it gives +--------------------------------------+----------+--------------+------+-------------+-------------+ | ID | Status | Display Name | Size | Volume Type | Attached to | +--------------------------------------+----------+--------------+------+-------------+-------------+ | 8802e55c-29a6-4087-9730-286cfbd3fdb3 | creating | test | 1 | None | | +--------------------------------------+----------+--------------+------+-------------+-------------+

the status of the volume should be 'Available', But in my case it still remains in 'creating' state

and my cinder.conf looks like, [DEFAULT] rootwrap_config = /etc/cinder/rootwrap.conf sql_connection = mysql://cinder:openstack@.../cinder api_paste_confg = /etc/cinder/api-paste.ini

iscsi_helper = ietadm volume_name_template = volume-%s volume_group = cinder-volumes verbose = True auth_strategy = keystone state_path = /var/lib/cinder volumes_dir = /var/lib/cinder/volumes #osapi_volume_listen_port=5900

and the part of my api-paste.ini file looks like, [filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = x.y.z.a service_port = 5000 auth_host = x.y.z.a auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = cinder admin_password = openstack

Please help me fix it..

Its urgent i need..

regards Rajesh kannan

edit retag flag offensive close merge delete

29 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-08 12:14:16 -0500

try to run a cinder delete $id otherwhise, edit manually the database and set the "deleted" field to 1 since the volume doesn't exist

edit flag offensive delete link more
0

answered 2012-11-08 12:13:35 -0500

try to run

edit flag offensive delete link more
0

answered 2012-11-08 11:35:02 -0500

rajeshkannan007 gravatar image

Can you tell me the way to delete the available volume..

I tried it.. but now the status remains 'error_deleting'

can i delete the available volume? if so please tell me the command..

otherwise how to make it as available again..?

thanks and regards, R.Rajesh kannan

edit flag offensive delete link more
0

answered 2012-11-08 08:42:51 -0500

Can you try to create a bigger file (let's say 3 gb) and try again both fsdisk and the mount/ pvcreate, etc... thanks

edit flag offensive delete link more
0

answered 2012-11-08 05:24:03 -0500

rajeshkannan007 gravatar image

No I'm using sudo for the mounting and lvm ones..

Because after using sudo only its executed.. otherwise its not working..

edit flag offensive delete link more
0

answered 2012-11-07 14:28:09 -0500

it's like you don't have some rights over it. are you using the same user for all the tasks ? and the root one for the mounting and lvm ones ?

edit flag offensive delete link more
0

answered 2012-11-07 04:15:13 -0500

rajeshkannan007 gravatar image

This is the output of running fdisk and pressing "p"

You will not be able to write the partition table.

Command (m for help): p

Disk cinder-volumes: 2147 MB, 2147483648 bytes 22 heads, 16 sectors/track, 11915 cylinders, total 4194304 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0xe0b9daf4

     Device Boot      Start         End      Blocks   Id  System

cinder-volumes1 2048 4194303 2096128 8e Linux LVM

edit flag offensive delete link more
0

answered 2012-11-06 12:38:03 -0500

rajeshkannan007 gravatar image

$ losetup -a returns nothing..

edit flag offensive delete link more
0

answered 2012-11-06 12:30:30 -0500

Looks like the loopfile is not mounted, what losetup -a shows ?

edit flag offensive delete link more
0

answered 2012-11-06 11:39:35 -0500

rajeshkannan007 gravatar image

Hi thanks for your reply..

i followed your steps..

but when i executed $ pvcreate /dev/loop2 it shws an error,

/dev/loop2: Size must exceed minimum of 1024 sectors. Failed to setup physical volume "/dev/loop2"

What should i do now..?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-05 12:18:47 -0500

Seen: 693 times

Last updated: Nov 21 '12