Ask Your Question
0

AttributeError: 'Client' object has no attribute 'set_auth_token'

asked 2011-08-03 06:53:06 -0600

tonytkdk gravatar image

Could someone have a test for me to confirm this ERROR. OS: Natty Server b64 Nova-compute : 2011.3~d4~20110802.1360-0ubuntu0ppa1~natty1

All-in-one host works perfectly And the additional nova-compute node failed to fire up instance due to an ERROR

====nova-compute.log ==== http://pastebin.com/BBfupk72

(nova.exception): TRACE: AttributeError: 'Client' object has no attribute 'set_auth_token'

And image caching size on additional node is 0 The configuration is same as all-in-one host...I did not saw this error before and without any result with google.

It might be a bug ... but before that , hope someone could help me to confirm this issue.

Cheers Hugo Kuo

edit retag flag offensive close merge delete

5 answers

Sort by » oldest newest most voted
0

answered 2011-08-03 15:44:03 -0600

tonytkdk gravatar image

Thanks ..... Which reversion do u mean in trunk version? I remember that I'm running glance with r177 today. Is there any newer version? And an additional question is where can I dig out some more info about keystone?

Cheers Hugo Kuo

從我的 iPhone 傳送

Brian Waldon question166783@answers.launchpad.net 於 2011/8/3 下午8:21 寫道:

Your question #166783 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/166783 (https://answers.launchpad.net/nova/+q...)

Status: Open => Answered

Brian Waldon proposed the following answer: Update glance to trunk. There were some recent changes to start supporting auth tokens with Keystone that caused the Client interface to change a bit. Sorry for the problems it caused you!


If this answers your question, please go to the following page to let us know that it is solved: https://answers.launchpad.net/nova/+question/166783/+confirm?answer_id=0 (https://answers.launchpad.net/nova/+q...)

If you still need help, you can reply to this email or go to the following page to enter your feedback: https://answers.launchpad.net/nova/+question/166783 (https://answers.launchpad.net/nova/+q...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2011-08-04 18:23:54 -0600

@Donal: I haven't. Make sure your config file is in the right place and well-formed. If you continue to have a problem, please ask it in another launchpad question. Thanks!

edit flag offensive delete link more
0

answered 2011-08-04 17:45:29 -0600

Did you notice the config file failing to be read after updating to trunk? I get:

ERROR: Unable to locate any configuration file. Cannot load application glance-api

edit flag offensive delete link more
0

answered 2011-08-03 19:40:45 -0600

Make sure glance is up to date (at least rev 177) on the secondary node where the error occurred.

Sorry, I can't help you on keystone. Somebody should be able to help out in #openstack.

edit flag offensive delete link more
0

answered 2011-08-03 12:16:53 -0600

Update glance to trunk. There were some recent changes to start supporting auth tokens with Keystone that caused the Client interface to change a bit. Sorry for the problems it caused you!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-08-03 06:53:06 -0600

Seen: 442 times

Last updated: Aug 04 '11