Ask Your Question
0

Horizon Apache launch error

asked 2013-06-13 09:14:21 -0500

willierjyt gravatar image

Hi, I installed the horizon (stable/grizzly) in frdora 18 , after installation all works fine. But when i lanch the browser , the pages print that

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log.

and i run command tailf /var/log/httpd/horizon_error.log said

[Thu Jun 13 16:48:37.022157 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] mod_wsgi (pid=42531): Exception occurred processing WSGI script '/opt/stack/horizon/openstack_dashboard/wsgi/django.wsgi'. [Thu Jun 13 16:48:37.022285 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] Traceback (most recent call last): [Thu Jun 13 16:48:37.022334 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 219, in __call__ [Thu Jun 13 16:48:37.022418 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] self.load_middleware() [Thu Jun 13 16:48:37.022444 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 39, in load_middleware [Thu Jun 13 16:48:37.022482 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] for middleware_path in settings.MIDDLEWARE_CLASSES: [Thu Jun 13 16:48:37.022505 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/utils/functional.py", line 184, in inner [Thu Jun 13 16:48:37.022541 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] self._setup() [Thu Jun 13 16:48:37.022563 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 42, in _setup [Thu Jun 13 16:48:37.022597 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] self._wrapped = Settings(settings_module) [Thu Jun 13 16:48:37.022618 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 93, in __init__ [Thu Jun 13 16:48:37.022649 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] mod = importlib.import_module(self.SETTINGS_MODULE) [Thu Jun 13 16:48:37.022671 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/usr/lib/python2.7/site-packages/django/utils/importlib.py", line 35, in import_module [Thu Jun 13 16:48:37.022704 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] __import__(name) [Thu Jun 13 16:48:37.022725 2013] [:error] [pid 42531] [remote 192.168.1.110:24231] File "/opt/stack/horizon/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 182, in <module> [Thu Jun 13 16:48:37.022762 2013] [:error] [pid 42531] [remote 192 ... (more)

edit retag flag offensive close merge delete

9 answers

Sort by » oldest newest most voted
0

answered 2015-10-22 08:27:17 -0500

adendukuri gravatar image

Is your problem solved? there are couple steps that were missing in the document that you need to complete.

following steps were missing 2. Set up a web server with WSGI support. It is optional but recommended in production deployments. For example, install Apache web server on Ubuntu:

sudo apt-get install apache2 libapache2-mod-wsgi - completed

  1. generate an /etc/openstack_dashboard/wsgi/horizon.wsgi file using the following command /usr/share/openstack-dashboard/manage.py make_web_conf --wsgi

  2. create /etc/apache2/sites-available/horizon.conf file using . /usr/share/openstack-dashboard/manage.py make_web_conf --apache > /etc/apache2/sites-available/horizon.conf

  3. Finally we need to start apache2 and memcached services

then launch horizon from any web browser

Hope this helps

edit flag offensive delete link more
0

answered 2013-06-13 10:21:37 -0500

jpichon gravatar image

Excellent, thanks for the update. Glad you solved it!

edit flag offensive delete link more
0

answered 2013-06-13 09:20:04 -0500

jpichon gravatar image

I think LockFailed is related to a SELinux issue. You can try doing "setenforce 0" and see if that solves it. Unfortunately, I don't know which SELinux boolean in particular needs to be turned on if you want to keep SELinux enabled (please post an update if you figure it out!).

edit flag offensive delete link more
0

answered 2013-06-13 09:40:25 -0500

willierjyt gravatar image

Thanks Julie Pichon, that solved my question.

edit flag offensive delete link more
0

answered 2013-06-13 09:44:50 -0500

willierjyt gravatar image

I tried using setenforce 0 but i still does't work. It really confused me . I chang the ownership of /opt/stack/horizon/openstack_dashboard/local/ to nobody:nobody , it does't make sense at all.

edit flag offensive delete link more
0

answered 2013-06-13 10:09:54 -0500

willierjyt gravatar image

Hi, i just solve it by rewriting some code of local_settings.py file. The previous LOCAL_PATH = os.path.dirname(os.path.abspath(__file__)) , and then i change it to LOCAL_PATH = '/tmp' . Besides i change the ownership of folders of horizon to stack:stack . Now all works fine.

edit flag offensive delete link more
0

answered 2013-07-01 06:34:48 -0500

Hi, it can fix this bug on the fedora 18.if you change it to LOCAL_PATH = '/tmp',it will report the error "unable to apply CompilerFilter" . I fix it by add ” os.system('setenforce 0') “ in local_settings.py. pls update it.

edit flag offensive delete link more
0

answered 2013-08-02 11:22:11 -0500

mrunge gravatar image

Is apache able to write to /opt/stack/horizon/openstack_dashboard?

You can verify, this isn't related to selinux be setting temporarily selinux to permissive: setenforce permissive

edit flag offensive delete link more
0

answered 2013-08-02 11:26:01 -0500

mrunge gravatar image

You probably want to change 'LOCAL_PATH' from your openstack_dashboard/local/local_settings.py.example (resp. local_setting.py) to something like '/tmp'.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-13 09:14:21 -0500

Seen: 2,584 times

Last updated: Oct 22 '15