Ask Your Question
0

Unable to connect to the dahsboard server with error

asked 2013-12-10 23:12:54 -0500

alfredcs gravatar image

Getting following error when running openstack-dashboard-2013.2-4 with Havana code on controller node wpc0016. The Not found files do exist and this could be a simple configuration issue. Not sure where the problem is. Any help will be appreciated.


[root@wpc0016 openstack-dashboard]# ps -ef | grep manage root 4240 3470 0 23:03 pts/0 00:00:00 python /usr/share/openstack-dashboard/manage.py runserver 0.0.0.0:8080 root 4245 4240 0 23:03 pts/0 00:00:04 /usr/bin/python /usr/share/openstack-dashboard/manage.py runserver 0.0.0.0:8080


0 errors found Django version 1.4.6, using settings 'openstack_dashboard.settings' Development server is running at http://0.0.0.0:8080/ Quit the server with CONTROL-C. Not Found: /dashboard/ DeprecationWarning: Authentication backends without a supports_inactive_user attribute are deprecated. Please define it in <class 'openstack_auth.backend.keystonebackend'="">.[10/Dec/2013 23:03:31] "GET /dashboard/ HTTP/1.1" 404 3385 Not Found: /static/dashboard/css/f0973a54f9a4.css [10/Dec/2013 23:03:31] "GET /static/dashboard/css/f0973a54f9a4.css HTTP/1.1" 404 3385 Not Found: /static/dashboard/js/588884c5a22a.js [10/Dec/2013 23:03:31] "GET /static/dashboard/js/588884c5a22a.js HTTP/1.1" 404 3385 Not Found: /static/dashboard/js/271a130e6a31.js [10/Dec/2013 23:03:31] "GET /i18n/js/horizon/ HTTP/1.1" 200 2158

[10/Dec/2013 23:03:31] "GET /static/dashboard/js/271a130e6a31.js HTTP/1.1" 404 3385

[root@wpc0016 openstack-dashboard]# cat /etc/httpd/conf.d/openstack-dashboard.conf WSGIDaemonProcess dashboard WSGIProcessGroup dashboard WSGISocketPrefix run/wsgi

WSGIScriptAlias /dashboard /usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi Alias /static /usr/share/openstack-dashboard/static

<directory usr="" share="" openstack-dashboard="" openstack_dashboard="" wsgi=""> <ifmodule mod_deflate.c=""> SetOutputFilter DEFLATE <ifmodule mod_headers.c=""> # Make sure proxies don’t deliver the wrong content Header append Vary User-Agent env=!dont-vary </ifmodule> </ifmodule>

Order allow,deny Allow from all </directory>

<directory usr="" share="" openstack-dashboard="" static=""> <ifmodule mod_expires.c=""> ExpiresActive On ExpiresDefault "access 6 month" </ifmodule> <ifmodule mod_deflate.c=""> SetOutputFilter DEFLATE </ifmodule>

Order allow,deny Allow from all

</directory>

[root@wpc0016 openstack-dashboard]# ls -l /usr/share/openstack-dashboard/static/dashboard/js/588884c5a22a.js -rwxr-xr-x 1 root root 789 Dec 3 08:33 /usr/share/openstack-dashboard/static/dashboard/js/588884c5a22a.js

[root@wpc0016 openstack-dashboard]# ls -l /usr/share/openstack-dashboard/static/dashboard/js/271a130e6a31.js -rwxr-xr-x 1 root root 524376 Dec 3 08:33 /usr/share/openstack-dashboard/static/dashboard/js/271a130e6a31.js

edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
0

answered 2013-12-11 01:03:49 -0500

alfredcs gravatar image

Thanks Matthias for getting back. Unfortunately it didn't seem to help. Pls see the logs

----------------------- Install lesscpy ----- [root@wpc0016 tmp]# pip list | grep less lesscpy (0.6)

------------------- Modified COMPRESS_OFFLINE to False ------

[root@wpc0016 usr]# cat ./share/openstack-dashboard/openstack_dashboard/settings.py | grep COMPRESS_OFFLINE #COMPRESS_OFFLINE = True COMPRESS_OFFLINE = False

------------------- Restarted httpd and openstack-dashboard --------

Not Found: /flavors/ [11/Dec/2013 00:57:13] "GET /flavors/ HTTP/1.1" 404 3385 Not Found: /static/dashboard/less/rhtheme.less Not Found: /static/dashboard/js/588884c5a22a.js Not Found: /static/dashboard/js/271a130e6a31.js [11/Dec/2013 00:57:13] "GET /i18n/js/horizon/ HTTP/1.1" 200 2158 [11/Dec/2013 00:57:13] "GET /static/dashboard/less/rhtheme.less HTTP/1.1" 404 3385 [11/Dec/2013 00:57:13] "GET /static/dashboard/js/588884c5a22a.js HTTP/1.1" 404 3385 [11/Dec/2013 00:57:13] "GET /static/dashboard/js/271a130e6a31.js HTTP/1.1" 404 3385 Not Found: /static/dashboard/img/rhfavicon.ico [11/Dec/2013 00:57:14] "GET /static/dashboard/img/rhfavicon.ico HTTP/1.1" 404 3385 [11/Dec/2013 00:57:35] "GET / HTTP/1.1" 302 0 Internal Server Error: /admin/ Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/django/core/handlers/base.py", line 111, in get_response response = callback(request, callback_args, *callback_kwargs) File "/usr/lib/python2.6/site-packages/horizon/decorators.py", line 38, in dec return view_func(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/horizon/decorators.py", line 86, in dec return view_func(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/horizon/decorators.py", line 54, in dec return view_func(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/horizon/decorators.py", line 38, in dec return view_func(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/horizon/decorators.py", line 86, in dec return view_func(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/django/views/generic/base.py", line 48, in view return self.dispatch(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/django/views/generic/base.py", line 69, in dispatch return handler(request, args, *kwargs) File "/usr/lib/python2.6/site-packages/horizon/tables/views.py", line 155, in get handled = self.construct_tables() File "/usr/lib/python2.6/site-packages/horizon/tables/views.py", line 146, in construct_tables handled = self.handle_table(table) File "/usr/lib/python2.6/site-packages/horizon/tables/views.py", line 118, in handle_table data = self._get_data_dict() File "/usr/lib/python2.6/site-packages/horizon/tables/views.py", line 182, in _get_data_dict self._data = {self.table_class._meta.name: self.get_data()} File "/usr/share/openstack-dashboard/openstack_dashboard/dashboards/admin/overview/views.py", line 59, in get_data data = super(GlobalOverview, self).get_data() File "/usr/share/openstack-dashboard/openstack_dashboard/usage/views.py", line 28, in get_data self.usage.summarize(*self.usage.get_date_range()) File "/usr/share/openstack-dashboard/openstack_dashboard/usage/base.py", line 193, in summarize _('Unable to retrieve usage information.')) File "/usr/share/openstack-dashboard/openstack_dashboard/usage/base.py", line 190, in summarize self.usage_list = self.get_usage_list(start, end) File "/usr/share ... (more)

edit flag offensive delete link more
0

answered 2013-12-11 23:07:45 -0500

alfredcs gravatar image

updated to python-django-openstack-auth-1.1.2-1.el6.noarch seemed to help solving part of the problem. Thanks Matthias. The dashboard still can only display text, no graphics. Will continue digging-in further.

edit flag offensive delete link more
0

answered 2013-12-10 23:39:47 -0500

mrunge gravatar image

for me, it looks like there is a compression issue.

If you don't have already installed, you should install python-lesscpy (or how the package is called in your distribution, and switch off COMPRESS_OFFLINE (in settings.py)

edit flag offensive delete link more
0

answered 2013-12-11 08:18:46 -0500

mrunge gravatar image

Did you do an update/upgrade? If yes, please clear your cookies for your horizon controller.

I think I remember this issue. The problem was, django_openstack_auth was outdated. For Havana, I'd use at least django_openstack_auth >= 1.1.0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-10 23:12:54 -0500

Seen: 1,196 times

Last updated: Dec 11 '13