Ask Your Question
0

503 error running multiple-server

asked 2011-06-17 11:11:49 -0500

shengjie-min gravatar image

I I've been following the instruction on http://swift.openstack.org/howto_installmultinode.html#configure-the-proxy-node (http://swift.openstack.org/howto_inst...) . I have three storage and a proxy server running as 4 vms(host only). proxy server: 192.168.175.128 storage 1 : 192.168.175.130 storage 2 :192.168.175.131 storage 3 :192.168.175.133

ring builds perfectly, rebalanced perfectly. rm -f .builder *.ring.gz backups/.builder backups/*.ring.gz

swift-ring-builder object.builder create 18 3 1 swift-ring-builder object.builder add z1-192.168.175.130:6000/sda3 1 swift-ring-builder object.builder add z2-192.168.175.131:6000/sda3 1 swift-ring-builder object.builder add z3-192.168.175.133:6000/sda3 1 swift-ring-builder object.builder rebalance

swift-ring-builder container.builder create 18 3 1 swift-ring-builder container.builder add z1-192.168.175.130:6001/sda3 1 swift-ring-builder container.builder add z2-192.168.175.131:6001/sda3 1 swift-ring-builder container.builder add z3-192.168.175.133:6001/sda3 1 swift-ring-builder container.builder rebalance

swift-ring-builder account.builder create 18 3 1 swift-ring-builder account.builder add z1-192.168.175.130:6002/sda3 1 swift-ring-builder account.builder add z2-192.168.175.131:6002/sda3 1 swift-ring-builder account.builder add z3-192.168.175.133:6002/sda3 1 swift-ring-builder account.builder rebalance

When I was trying to start proxy server, tempauth was not working, and then I noticed swauth is still installed with in swift(I can see all the swauth commands files, like swauth-prep, swauth-add-user under /usr/bin), I've changed my proxy-server.conf as below

[DEFAULT] #cert_file = /etc/swift/cert.crt #key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] use = egg:swift#swauth default_swift_cluster = local#http://192.168.175.128:8080/v1#http://localhost:8080/v1 super_admin_key = swauthkey

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache

memcache_servers = 192.168.175.128:11211

then when i try to run

root@ubuntu:/etc/swift# swauth-prep -K swauthkey

Auth subsystem prep failed: 500 Server Error

I get this error in sys.log

Jun 17 04:08:32 ubuntu proxy-server Account PUT returning 503 for [503, 503, 503] (txn: tx9fadfec6-1f85-4e8f-9982-2987bc44465d) Jun 17 04:08:32 ubuntu proxy-server - - 17/Jun/2011/11/08/32 PUT /v1/AUTH_.auth HTTP/1.0 503 - - - - - - tx9fadfec6-1f85-4e8f-9982-2987bc44465d - 0.0125 Jun 17 04:08:32 ubuntu proxy-server STDOUT: EXCEPTION IN handle: Traceback (most recent call last):#012 File "/usr/lib/pymodules/python2.6/swift/common/middleware/swauth.py", line 320, in handle#012 return self.handle_request(req)(env, start_response)#012 File "/usr/lib/pymodules/python2.6/swift/common/middleware/swauth.py", line 383, in handle_request#012 req.response = handler(req)#012 File "/usr/lib/pymodules/python2.6/swift/common/middleware/swauth.py", line 402, in handle_prep#012 (path, resp.status))#012Exception: Could not create the main auth account: /v1/AUTH_.auth 503 Internal Server Error#012: {'SCRIPT_NAME': '/auth/v2', 'webob.adhoc_attrs': {'start_time': 1308308912.1579649, 'bytes_transferred': '-', 'client_disconnect': False}, 'REQUEST_METHOD': 'POST', 'PATH_INFO': '/.prep ... (more)

edit retag flag offensive close merge delete

12 answers

Sort by » oldest newest most voted
0

answered 2011-06-17 16:16:14 -0500

gholt gravatar image

There is work planned to improve logging and documentation, etc. But all that takes time. We mostly throw stack traces because, though they're ugly, they tend to help more than "error reading file". :)

The HTTP codes are almost always standard, or at least /real/ close. 507 means "Insufficient Storage" and though we're using for "Unmounted" that's a pretty close match.

The only non-standard codes I'm aware Swift logs are:

498 Rate-Limiting In Effect 499 Client Disconnected Early

edit flag offensive delete link more
0

answered 2013-07-14 01:54:27 -0500

juhu2 gravatar image

I also meet this problem when running "swift stat". I find some error in the /var/log/message:

swift Node error limited 192.168.1.30:6002 (node) (txn: tx395f4fc90fb44e368aace4db659045d4) swift Account HEAD returning 503 for [] (txn: tx395f4fc90fb44e368aace4db659045d4) (client_ip: 192.168.1.30)

By reading the reply of gholt (gholt) said on 2011-06-17, I try to append "mount_check = false" to the config file of account-server.conf, container-server.conf, object-server.conf. Then this issue is disappear.

Thand for gholt.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-06-17 11:11:49 -0500

Seen: 113 times

Last updated: Jul 14 '13