Ask Your Question

Nova-compute state not ':-)'

asked 2012-07-17 05:40:05 -0500

ujuc gravatar image (

I installing OpenStack.. used StackGeek script..

but.. nova-compute state not ':-)'

$ nova-manage service list 2012-07-16 19:31:14 DEBUG nova.utils [req-1f024c82-2734-4df8-9db9-a1867385cbbf None None] backend <module 'nova.db.sqlalchemy.api'="" from="" '="" usr="" lib="" python2.7="" dist-packages="" nova="" db="" sqlalchemy="" api.pyc'=""> from (pid=3156) __get_backend /usr/lib/python2.7/dist-packages/nova/ Binary Host Zone Status State Updated_At nova-volume server nova enabled :-) 2012-07-16 10:31:06 nova-scheduler server nova enabled :-) 2012-07-16 10:31:09 nova-compute server nova enabled XXX 2012-07-16 10:12:43 nova-network server nova enabled :-) 2012-07-16 10:31:08 nova-cert server nova enabled :-) 2012-07-16 10:31:07

It's.. $ nova-manage service disable service nova-compute $ nova-manage service enable service nova-compute used command.. nova-compuate start... and state ':-)' after 1min.... nova-compute state 'XXX'



--dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --allow_admin_api=true --use_deprecated_auth=false --auth_strategy=keystone --scheduler_driver=nova.scheduler.simple.SimpleScheduler --s3_host= --ec2_host= --rabbit_host= --cc_host= --nova_url= --routing_source_ip= --glance_api_servers= --image_service=nova.image.glance.GlanceImageService --iscsi_ip_prefix=192.168.22 --sql_connection=mysql://nova:root00@ --ec2_url= --keystone_ec2_url= --api_paste_config=/etc/nova/api-paste.ini --libvirt_type=kvm --libvirt_use_virtio_for_bridges=true --start_guests_on_host_boot=true --resume_guests_state_on_host_boot=true --vnc_enabled=true --vncproxy_url= --vnc_console_proxy_url=

network specific settings --public_interface=eth0 --flat_interface=eth1 --flat_network_bridge=br100 --fixed_range= --floating_range= --network_size=32 --flat_network_dhcp_start= --flat_injected=False --force_dhcp_release --iscsi_helper=tgtadm --connection_type=libvirt --root_helper=sudo nova-rootwrap --verbose

plz..... :-( nova-compute state ':-)'... help...

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted

answered 2012-07-17 05:44:14 -0500

ujuc gravatar image

I'm used VMware..

CPU VT setting on~...

edit flag offensive delete link more

answered 2012-07-18 10:45:42 -0500

johngarbutt gravatar image

Looking at your logs, it seems like libvirt isn't working on your system.

Have you tried using virsh to debug your libvirt setup? Looks like nova can't talk to libvirt.

Not used stackgeek myself, maybe try ask those guys directly, or try

edit flag offensive delete link more

answered 2012-07-19 01:09:23 -0500

ujuc gravatar image

Thank~~~~~~~~~~~!!!!! John :-)~~~~~

edit flag offensive delete link more

answered 2012-07-19 13:40:16 -0500

johngarbutt gravatar image

No problem :-)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2012-07-17 05:40:05 -0500

Seen: 51 times

Last updated: Jul 19 '12