Ask Your Question
0

Change Router IP Address

asked 2013-05-19 01:48:39 -0500

Agung Ridwan gravatar image

When attaching interface of router to selected network, by default quantum use ip address .1 for interface. When I create new router and want to attach to the same network then it becoming error. I've tried to connect it manually with "veth peer" and ovs-vsctl add-port, but I couldn't ping to qr-ID of R1.
Here's the topology I built:
 +-----+----> external network (br-ex)
[R1] [R2]
  |        |
 +------+----> internal network (br-int)

I've tried in another PC (with no openstack): SUCCESS.
Do I need to generate port ID (for qr-XX interface of R2 and tapXX)?

edit retag flag offensive close merge delete

Comments

Is it the iptables?

Agung Ridwan gravatar imageAgung Ridwan ( 2013-05-19 02:37:18 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2013-05-20 07:39:04 -0500

Agung Ridwan gravatar image

I found the solution. Because I'm using OpenFlow, so I need to add-flow to the port.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-19 01:48:39 -0500

Seen: 108 times

Last updated: May 20 '13