Ask Your Question
0

can't see volume storage in instance ,is this a bug ??

asked 2010-11-16 09:35:49 -0500

tonytkdk gravatar image

http://i217.photobucket.com/albums/cc280/tonytkdk/volok.jpg (http://i217.photobucket.com/albums/cc...)

I install NOVA in single machine by novascript

the volume status is in-use /dev/vdb

but I can't see that in the instance..................

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2010-11-18 05:40:06 -0500

tonytkdk gravatar image

Thanks Vish Ishaya, that solved my question.

edit flag offensive delete link more
0

answered 2010-11-17 03:56:12 -0500

tonytkdk gravatar image

I try to attach volume and instance by /dev/vdb /dev/sdb /dev/vdc etc.... there were nothing addition to /proc/partitions

======================================================== root@openstack:/# euca-attach-volume -i i-8vpt88 -d /dev/sdb vol-rt2boi0h VOLUME vol-rt2boi0h

root@openstack:/# ssh -i test.pem root@10.0.0.3

-- This lightweight software stack was created with FastScale Stack Manager -- For information on the FastScale Stack Manager product,

-- please visit http://www.fastscale.com

-bash-3.2# cat /proc/partitions major minor #blocks name

252 0 153631 vda

252 1 153600 vda1

no any error in each worker screen...........

is possible that bcz I use a loopback device on the same computer with instance?

shoulda I or can I use volumes on SWIFT?

but I didn't see any flag to config volume storage location.
--storage_dev=//SWIFT_ADD

edit flag offensive delete link more
0

answered 2010-11-16 17:54:12 -0500

vishvananda gravatar image

ami-tiny is an ultra small busybox image and it doesn't have udev set up properly if you cat /proc/partitions you should see the device listed. You can make the traditional /dev/vd* using mknod grep vdb /proc/partitions | awk '{print "mknod /dev/"$4" b "$1" "$2}'

On Nov 16, 2010, at 1:35 AM, Hugo Kou wrote:

New question #134257 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

http://i217.photobucket.com/albums/cc...

I install NOVA in single machine by novascript

the volume status is in-use /dev/vdb

but I can't see that in the instance..................


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2010-11-16 09:35:49 -0500

Seen: 55 times

Last updated: Nov 18 '10